I-doit/Request Tracker mit https geht nicht



  • Hallo,

    wenn man Request Tracker hinter https betreibt, funktioniert die i-doit Integration nicht.

    Bis zur Version 1.1 habe ich nach jedem Update in

    src/classes/protocol/isys_protocol_http.class.php

    folgende Zeile modifiziert:

    public static function get_instance($p_host, $p_port = 80, $p_protocol = self::C__HTTP)  wurde zu

    public static function get_instance($p_host, $p_port = 443, $p_protocol = self::C__HTTPS)

    In der 1.1.1 hat das nicht mehr geholfen. Auf die Schnelle habe ich nun die Zeile 248 modifiziert und die Variablen für Port und Protokoll im Funktionsaufruf durch Konstanten ersetzt.

    return "https://{$this->m_host}:443{$this->m_base_url}{$p_path}";

    Es hat sich also offensichtlich etwas geändert. Kann man Protokoll und Port nun irgendwo als Parameter angeben? Das wäre in jedem Fall eleganter, als mein Flickwerk.

    Viele Grüße,
    Matthias



  • ich habe noch mal die Doku durchgeschaut und gesehen, dass die RT Integration unter dem Menüpunkt "Module" konfigurierbar sein soll.

    Den Menüpunkt habe ich aber (auch als admin) gar nicht. Kann man den irgendwie freischalten?

    Ich habe den RT bis jetzt nur unter Schnittstelle/externe Daten/TroubleTicket-System konfiguriert und sehe sowohl Daten im RT und kann über die RT Erweiterung im RT auch Objekte im i-Doit referenzieren… Grundsätzlich geht das also.

    Viele Grüße,

    Matthias


 


Datenschutz / Privacy Policy