Problem mit LDAP-Authentifizierung über AD-2003



  • Tach auch,

    nachdem ich das i-doit-System (Version 0.9.9-7) unter Debian soweit fertig eingerichtet habe, bin ich nun dabei die LDAP-Authentifizierung zum Laufen zu bringen.

    Allerdings ist es nicht möglich sich mit einem User-Account der vorkonfigurierten OU am i-doit-System einzuloggen. Es erscheint die Fehlermeldung "Invalid username or password!". Die bereits vorhandenen Forumeinträge konnten mir leider auch nicht großartig weiterhelfen. Einen Auszug aus der ldap_debug.txt gibt es unten.

    Hier zunächst die entsprechenden Einstellungen:

    LDAP-Mapping:

    Einträge wurden der Doku entnommen und auch via ADSIEdit überprüft.

    LDAP-Server:

    Auszug aus der ldap_debug.txt

    
    2012-02-13 14:17:07 ldap: Connected to master-dc.domäne.de
    2012-02-13 14:17:07 ldap: Connection successfull.
    2012-02-13 14:17:07 ldap: Found 3 object(s) in OU=Systemadministratoren,OU=ITS - Informationstechnologie und -systeme,OU=AZD - Abteilung Zentrale Dienste,OU=Benutzer - Ordnerumleitung,DC=domäne,DC=de
    
    

    Wie man sieht, verläuft der Connection-Test erfolgreich und es werden 3 User-Objekte gefunden, was auch völlig richtig ist.
    Es ist ebenfalls möglich zusätzlich nach dem sAMAccountName=testy filtern zu lassen. Hier findet er dann logischerweise genau 1 Objekt.

    Bei der richtigen Anmeldung jedoch scheint es Probleme mit der Abfrage der Benutzer-Objekte zu geben.
    Auszug aus der ldap_debug.txt

    2012-02-13 14:42:58 ldap: LDAP Module launched for mandator: idoit_data
    2012-02-13 14:42:58 ldap: Found 1 configured LDAP Servers.
    2012-02-13 14:42:58 ldap: 1: master-dc.domäne.de (OU=Systemadministratoren,OU=ITS - Informationstechnologie und -systeme,OU=AZD - Abteilung Zentrale Dienste,OU=Benutzer - Ordnerumleitung,DC=domäne,DC=de)
    2012-02-13 14:42:58 ldap: ----------------------------------------------------------------------------------------------
    2012-02-13 14:42:58 ldap: Creating new ldap-library connection to: master-dc.domäne.de:389, user: CN=idoit,OU=DienstKonten,OU=Administration,DC=domäne,DC=de
    2012-02-13 14:42:58 ldap: Connected to master-dc.domäne.de
    2012-02-13 14:42:58 ldap: Searching for username: testy
    2012-02-13 14:42:58 ldap: Getting user(s) using filter: (&(&(objectClass=user)(objectClass=user)(sAMAccountName=testy)) in search-path: OU=Systemadministratoren,OU=ITS - Informationstechnologie und -systeme,OU=AZD - Abteilung Zentrale Dienste,OU=Benutzer - Ordnerumleitung,DC=domäne,DC=de
    2012-02-13 14:42:58 ldap: ** No user found.
    2012-02-13 14:42:58 ldap: User not found. Check if testy exist in your configured search-path: OU=Systemadministratoren,OU=ITS - Informationstechnologie und -systeme,OU=AZD - Abteilung Zentrale Dienste,OU=Benutzer - Ordnerumleitung,DC=domäne,DC=de
    2012-02-13 14:42:58 ldap: ----------------------------------------------------------------------------------------------
    2012-02-13 14:42:58 ldap: *** LDAP Auth failed. (false)
    
    

    Laut ldap_debug.txt findet das System bei der Abfrage plötzlich nicht mehr den sAMAccountName=testy in der festgelegten OU, bei dem Connection-Test allerdings schon.

    Hat jemand evtl. eine Idee wo das Problem liegen könnte?
    Für Ideen, Anmerkungen usw. wäre ich sehr dankbar 🙂

    Cheers
    Frans



  • Hat keiner eine Idee? Noch nicht mal ein I-Doit-Admin?? 😞



  • hatte/habe das selbe problem bei mir seit nov. bis jetzt auch noch keine brauchbare hilfe erhalten… 😞

    hier mein post...
    http://forum.i-doit.org/index.php/topic,2619.0.html



  • Hi chmon,

    Danke schon mal für deinen Post 🙂

    Dann sind wir ja zumindest schon Zwei, die scheinbar dasselbe Problem haben.

    Habe auch Wireshark mal mitsniffen lassen. Hier das Ergebnis beim Connection-Test:

    Man sieht, dass er hier die 3 vorhandenen User in der OU findet.

    Beim eigentlichen Login ist es allerdings genauso wie bei dir:

    Er überspringt komischerweise den "SearchRequest(2)", was wohl nicht ganz Sinn der Sache ist oder?


 


Datenschutz / Privacy Policy