Neue Versionen: i-doit 1.4 und Viva 1.4.1



  • Hallo zusammen,

    die neuen Versionen i-doit 1.4 und Viva 1.4.1 sind verfügbar.

    Folgende wichtige Änderungen an den beiden Produkten würde ich hiermit gerne hervorheben:

    Eine besonders wichtige Änderung in i-doit 1.4 hat die JSON-RPC Api erfahren: Hier kann man sich nun über zwei mögliche standardisierte Verfahren authentifizieren (z.b. ganz einfach per HTTP Basic Authentification). Diese Änderung hat zufolge, dass wir das veraltetes Login Verfahren über die Api abgeschafft haben (Konkret den 'session' Parameter). Diese Anpassung haben kündigen wir bei Benutzung innerhalb der Api bereits seit Version 1.2 an. Für genauere Details und die neue Vorgehensweise bitte in die Api Dokumentation der 1.4 schauen (Seite 12 ff.). Aktuell steht diese nur Subskriptionskunden über die Akademie zur Verfügung.

    Viva ist in dieser Version nur noch kompatibel zu i-doit 1.4! Ansonsten ist es mit dieser Version nun auch möglich die neuen Grundschutzkataloge zu importieren. Der etwas umständlichere Import wird in der Viva Dokumentation beschrieben.

    Weitere Details zu den Neuerungen und Anpassungen können unter http://www.i-doit.com/ressourcen/aktuelle-release-notes/ eingesehen werden.

    Grüße,
    ds



  • Nach dem Update auf idoit Version 1.4(.3) ist bei uns an diversen Stellen (z.B. in der Level 3 Net Listen Ansicht) folgender Fehler aufgetreten:
    array_unshift() expects parameter 1 to be array, null given (…/src/classes/helper/isys_helper_ip.class.php:846)

    Das Problem ist auf einen fehlerhaften String Compare zurückzuführen der bei bestimmten IPv6 IPs das Problem auslöst.

    Folgender Patch löst das Problem:

    
    --- a/src/classes/helper/isys_helper_ip.class.php
    +++ b/src/classes/helper/isys_helper_ip.class.php
    @@ -795,7 +795,7 @@ class isys_helper_ip
                                                    $l_address_arr[$l_key] = '0';
                                            }
    
    -                                       if ($l_part == '0' || $l_part == '0000')
    +                                       if ($l_part === '0' || $l_part === '0000')
                                            {
                                                    $l_all_null[] = $l_key;
                                            }
    
    


  • Der Fehler besteht auch in Version 1.4.4 weiterhin.


 


Datenschutz / Privacy Policy