Fehler: Netzwerk



  • Guten Morgen,

    beim Versuch einen Switch mit einem Patchpanel zu verbinden stieß ich auf folgenden Fehler:

    Fatal error: Class 'isys_report_dao' not found in D:\XAMPP\htdocs\idoit\src\classes\popups\isys_popup_browser_object_ng.class.php on line 302

    Diese Fehlermeldung erschien sowohl in der open Webversion, als auch in der heruntergeladenen Version, beim Aufrufen des Punktes Assigned to connector.

    Hat jemand eine Idee, woran dies liegen könnte?

    Besten Dank für die Hilfe schon mal im Voraus



  • Hallo liebes i-doit-Team,

    dies scheint wohl ein genereller Bug zu sein. Wir können den Fehler bestätigen. Scheint auch unabhängig von der Webserver-Installation zu sein. Unser Apache Webserver in Version 2.2.22 läuft auf einem aktuellen Debian 7.6 mit PHP in Version 5.4.4-14.
    Wäre schön, wenn ihr den Bug kurzfristig beheben könntet.

    Viele Grüße und danke vorab

    bzbadmin



  • Hallo liebes I-doit-Team,

    wir haben das selbe Problem mit "Assigned to connector". Sobald ich auf die Lupe klicke erscheint ein leeres Fenster. Im error.log steht folgendes:

    PHP Fatal error:  Class 'isys_report_dao' not found in …/idoit/src/classes/popups/isys_popup_browser_object_ng.class.php on line 302, referer: http://.../idoit/?objID=43&tvMode=1006&catgID=50&objTypeID=86&cateID=9&viewMode=1100&objGroupID=2&editMode=0

    Ein weiteres Problem gibt es wenn man unter Switch auf einen angelegten Switch klickt. Hier wird eine leere Seite angezeigt. Im error.log steht folgendes:

    PHP Fatal error:  Class 'isys_cmdb_dao_category_s_enclosure' not found in .../idoit/src/classes/factory/isys_factory_cmdb_category_dao.class.php on line 41, referer: http://.../?viewMode=1001&objTypeID=6

    Wär schön wenn Ihr uns damit weiter helfen könnt.

    MFG
    Sebastian



  • Hallo zusammen,

    um diesen Fehler etwas genauer einzugrenzen würde es sehr weiterhelfen wenn ihr jeweils die PHP und i-doit Version dazu schreibt.

    Viele Grüße
    Leo



  • Hallo Leo,

    wie bereits gestern geschrieben setzten wir die PHP-Version 5.4.4-14 auf Apache 2.2.22 unter Debian 7.6 ein. Die von uns verwendete i-doit-Version ist die neue i-doit open 1.4.2.

    Viele Grüße

    bzbadmin



  • Hallo Leo,

    sorry hab ich ganz Vergessen.

    i-doit 1.4.2 OPEN

    Debian 7.6
    Apache 2.2.22
    PHP 5.4.4-14

    MFG
    Sebastian



  • Hallo zusammen,

    wir nutzen:
    PHP Version 5.5.11
    Apache 2.4.9 (Win32)
    i-doit open 1.4.2

    Viele Grüße
    Ordo_ab_chao



  • Mich beschleicht hier langsam ein Verdacht, wenn ich mir die aktuelle Gegenüberstellung der Open- und Pro-Versionen ansehe (siehe Auszug in meiner Anlage).
    Für mich sieht es so aus, als hätte man die Netzwerkfunktion schlicht in der Open-Version entfernt, genauso wie man anscheinend auch andere Funktionen raus genommen hat (siehe: http://forum.i-doit.org/index.php/topic,3426.msg11148.html#msg11148)

    i-doit1.4.x.jpg



  • @bzbadmin:

    Mich beschleicht hier langsam ein Verdacht, wenn ich mir die aktuelle Gegenüberstellung der Open- und Pro-Versionen ansehe (siehe Auszug in meiner Anlage).
    Für mich sieht es so aus, als hätte man die Netzwerkfunktion schlicht in der Open-Version entfernt, genauso wie man anscheinend auch andere Funktionen raus genommen hat (siehe: http://forum.i-doit.org/index.php/topic,3426.msg11148.html#msg11148)

    Hallo Bzbadmin,

    keine Sorge - das ist nicht die Fehlerursache. Es ist zwar richtig, das einige Netzwerk Features entfernt wurden, jedoch gehören die Port Verbindungen (nach meinem Wissensstand) nicht dazu. Der genannte Fehler tritt wegen dem gestrichenen Report Manager auf - Im Objekt-Browser gibt es die Möglichkeit eine Liste von Objekten auf Basis eines Reports darstellen zu lassen… Hier müssen wir nachbessern!

    Viele Grüße
    Leo



  • Hallo bzadmin,

    gibt es schon eine Timeline mit welchen Update das Problem gelöst wird? Wir nutzen die Open als Evaluierung, da 30 Tage Demo einfach zu stressig sind;)

    vg Jörg

    PS: Im Moment läuft i-doit-open 1.4.4, on Debian 7.5, apache 2.2.22, php 5.4.4



  • Hallo sarem_avuton,

    ich bin auch nur Anwender, gebe die Frage aber gerne an Leo weiter… 😉

    @Leo: Möchte mich an die Frage von sarem_avuton gerne anschließen. Ich habe unsere 1.4.2er open gerade mal auf die 1.4.4 upgedated. Seither erhalte ich anstatt der ursprünglichen Fehlermeldung nur noch ein weißes Fenster. Daher würde mich auch interessieren, ob es schon eine Timeline für die Fehlerbehebung gibt.

    Danke und Gruß,
    bzbadmin



  • Hallo Leo,

    kommt das Feature noch in der Open? Oder gehört das zu den Features Visualisierung Portverbindungen, IP-Adressen/Netzen?

    VG Jörg

    2014-10-21 09_22_35-i-doit_ Überblick.png



  • Hallo zusammen,

    das ursprüngliche Problem "Fatal error: Class 'isys_report_dao' not found in D:\XAMPP\htdocs\idoit\src\classes\popups\isys_popup_browser_object_ng.class.php on line 302" sollte ja inzwischen gelöst sein. Die aktuellste i-doit (Open / PRO) Version lautet 1.4.7!

    Über die Features kann ich nicht bestimmen, ich kann allerdings sagen das die Liste auf unserer Webseite vor kurzem erst auf den neusten Stand gebracht wurde. Ich denke nicht, das es hier in nächster Zeit Änderungen geben wird.

    Viele Grüße
    Leo



  • Moinsen,

    habe im Moment den gleichen Fehler in der Open 1.4.7 und der Pro 1.4.7. Gibt es da in absehbarer Zeit eine Besserung? Würde gerne "idoit" in der neuen Variante hier im Betrieb vorstellen und nicht in der 0.9x Version… da lief noch alles.

    Gibt's nen ETA für den Patch?



  • Hallo zusammen,

    wir haben nun auf die aktuelle 1.4.7 open aktualisiert. Der Fehler mit der weißen Seite, den ich am 16.09. beschrieben habe, besteht auch nach der Aktualisierung noch. Siehe die beigefügten Screenshots.

    Gruß,
    bzbadmin

    Nachtrag: In einem der Apache-Access-Logs wird, sobald das weiße Fenster erscheint folgender Eintrag hinzugefügt:

    <server-fqdn>:80 <ip-adresse> - - [23/Oct/2014:10:35:46 +0200] "POST /?mod=cmdb&popup=browser_cable_connection_ng&live_preselection=&ajax=1 HTTP/1.1" 200 398 "http://<server-fqdn>/?objID=212&tvMode=1006&catgID=50&objTypeID=43&cateID=147&viewMode=1100&objGroupID=2&editMode=0" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0"</server-fqdn></ip-adresse></server-fqdn>
    

    Nur für den Fall, dass es von Nutzen ist…

    connectors.jpg
    connectors2.jpg



  • Hallo zusammen,

    wollte mal hören, ob's schon Neuigkeiten zu o.g. Problem gibt. Habe inzwischen auf 1.4.8 open aktualisiert. Fehler besteht immer noch, bekomme nur eine weiße Seite. Habe auch schon das Skript idoit-rights.sh getestet, da ich in einem anderen Thread gelesen habe, dass auftretende weiße Seiten meistens Berechtigung als Ursache haben. Hat aber auch nichts gebracht. Wäre schön, wenn das Problem zeitnah angegangen werden könnte. Für uns ist die Open-Version eine bessere Demo-Version, da zeitlich unbegrenzt. Wenn der Fehler aber weiterhin besteht, ist das Produkt für uns leider nicht zu gebrauchen und wir werden dann auch definitiv nicht auf die Pro wechseln, sondern uns nach einem alternativen Produkt umsehen. 😐



  • Oh hier gibt's ja schon einen Thread zu dem Thema was ich die Nacht eröffnet habe (Switch Ports verbinden).

    Also dann gleicher Fehler, idoit 1.4.4, 1.4.7 sowie 1.4.8 tritt überall der gleiche Fehler auf in einer frischen Neuinstallation. Mit kommt es vor als wäre die Funktion gesperrt???



  • Okay, habe jetzt mal die Pro als Demo installiert und siehe da, der Fehler tritt nicht auf. Es liegt als definitiv nicht an irgendwelchen fehlerhaften Einstellungen, Serversettings etc. sonder scheint entweder ein Bug oder eine gesperrte Funktion zu sein.



  • Hallo zusammen,

    wir werden uns das Problem erneut ansehen damit es mit der nächsten Version endgültig der Vergangenheit angehört 😉

    Viele Grüße
    Leo



  • Hi,

    gibt es schon Neuigkeiten oder Fortschritte ? Dieser "Bug" besteht jetzt schon so lange, dass ich langsam aber sicher Lust bekomme mich nach einer Alternative zu i-doit umzusehen. Die fehlende Möglichkeit Verkabelungen anzulegen macht das ganze System komplett unbrauchbar.


 


Datenschutz / Privacy Policy