Wiederherstellung Admin



  • Hallo,

    mir ist was blödes passiert. Ich habe es geschafft meine User über LDAP als Kontakte zu importieren. Da aber viele unnötige Kontakte dabei waren, habe ich die überzähligen archiviert. Leider waren dabei auch mein Admin Login. In welcher mysql Tabelle muß ich nun was eintragen, damit mein Admin User wieder auferstehen kann?

    Gruss
    swuest



  • Konnte mir selbst helfen:
    Hier eine mögliche Hilfestellung für diejenigen, denen ähnliches passiert. Es geht sicher eleganter und professioneller.

    isys_obj__status in der tabelle isys_obj gibt den zustand eines Objekts an. 3 heisst vermutlich archiviert, 2 aktiv.
    isys_obj__id inkrementiert und ist der Index für alle Objekte.  Die Ursprungsuser "Admin" "Archivar" etc. müssen niedrige isys_obj__id Werte besitzen, da sie bei der Installation des Systems erzeugt wurden.
    isys_obj__created zeigt das Erstellungsdatum/-zeitpunkt eines Objekts. Somit der Wert für "Admin" etc. nahe am Installationszeitraum von I-Doit liegen.
    isys_obj__created_by führt den Erzeuger des Systems auf. Hier ist i-doit wunderbar sauber und zeigt "System" als Erzeuger an.
    isys_obj__isys_obj_type__id gibt den Typ eines Objekts an: 53 = einzelne User, die Werte 54 und 60 sind mir nicht klar, Gruppen und Gruppenmitglieder?
    isys_obj__title gibt den Namen eins Objekts an. "guest","reader","editor","author","archivar","admin" scheinen wichtig zu sein 🙂

    Also:
    0. Mit mysqldump ein Backup der Datenbank. Ich bin hier im Blindflug unterwegs 🙂
    1.Mit mysql client mit der DB verbinden
    2. select * from isys_obj where isys_obj__status=3 and isys_obj__created_by="system";
    3. So jetzt Augen auf und sich die isys_obj_id der in Frage kommenden Objekte aufschreiben. (z.B. in meinem Fall ist die isys_obj_id = 22 wo der Wert von isys_obj__title = "admin" isys_obj__created_by "system" kommt auch hin)
    4. update isys_obj set isys_obj__status=2 where isys_obj__id= 22 (22 bitte durch Eure gefundenen IDs ersetzen)
    Fertig. Ich musste 3 Sek warten, dann konnte ich mich wieder über das Webinterface anmelden, meine Kiste ist extrem lahm.


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.