Beim Update falsche Version angezeigt



  • Hallo,

    ich habe heute von 1.4.8 auf 1.5.3 migriert.
    Ging problemlos.
    Leider hat der Load der Daten in MYSQL nicht ganz richtig funktioniert.
    Daher musste ich zurück auf die alte Version 1.4.8.
    Ich habe also das /idoit-Verzeichnis geleert und mit den 'alten' Daten wieder gefüllt.
    Wenn ich nun IDOIT aufrufe, wird als aktuelle Version 1.4.8 angezeit.
    Wenn ich dann auf UPDATES gehe, wird mir gesagt ich hätte 1.5.3 und es geht dann nicht mehr weiter.
    Kann man das irgendwie zurücksetzen?


  • i-doit Kenner

    Hallo urebmann,

    hast Du direkt von 1.4.8 auf 1.5.3 migriert? Du haettest mindestens ein Update auf die 1.5 als Zwischenschritt durchfuehren muessen.
    Meinst Du mit "Load der Daten in MYSQL" einen Dump? Dumps koennen nicht zwischen verschiedenen Versionen importiert werden, da die DB Strukturen regelmaessig veraendert werden!
    Du muesstest also ein Update von 1.4.8 auf 1.5 durchfuehren, anschliessend ein Update auf 1.5.3 (oder die aktuellste Version 1.5.4).
    Bei dem Update werden die DB ebenfalls migriert, wenn die Option aktiviert ist.

    Was wird Dir bei "i-doit Code/Database Version" unter Verwaltung > Systemtools > Systemuebersicht angezeigt?

    Gruss,
    jkondek



  • Hi jkondek,

    ja, ich habe den Zwischenschritt gemacht.
    In der Systemübersicht (danke für den Tipp!) habe ich dann gesehen dass die DB noch 1.5 ist.
    Also habe ich die DB auch nochmal auf den alten Stand gebracht und von vorne begonnen.
    Es hat auch alles funktioniert.
    Bevor ich dann aber auf 1.5.4 migriere, habe ich mir die Inhalte angeschaut.

    Dabei ist nun ein seltsames Phänomen aufgetaucht:

    In der Rubrik Software haben wir u.a. Betriebssysteme und Anwendungen verwaltet.
    Nun ist nach dem Updaten auf 1.5. die Anzahl bei Betriebssystemen von 71 auf 70, die Anwendungen von 280 auf 277
    geschrumpft. Das macht mich dann doch etwas nachdenklich 🙂


  • i-doit Kenner

    Hallo urebmann,

    das klingt schon ziemlich merkwuerdig. Hast Du denn die genaue ID von den Objekten, die fehlen? Du kannst diese in der Suche mit # eingeben, dann wird dieses Objekt aufgerufen, z.B. #1 im Suchfeld oeffnet bei mir die Root-Lokation.

    Darueber kannst Du mal pruefen, was aus Deinen verschollenen Objekten geworden ist.

    Gruss,
    jkondek



  • Also auf dem Quellsystem ist die ID da und die Seite wird auch angezeigt.
    Auf dem neuen System gibt es einen Fehler:

    Nachricht

    CMDB Error: Object with ID: 29130 does not exist.
    If you clicked on a link to reach this page (e.g. a bookmarked page), it might be broken and should be deleted.

    LG
    Uli



  • ich habe weitergeforscht und es tun sich Abgründe auf 🙂

    Wir haben vor der Migration in der Tabelle isys_obj genau 36618 Datensätze.
    Nach der Migration sind es in der Tabelle 36546 Sätze.
    Damit nicht genug:
    Es gibt in der migrierten Tabelle 60 Datensätze die vorher nicht da waren.
    Dann gibt es noch 72 Datensätze die ganz verschwunden sind.

    Ich bin etwas ratlos…..


 


Datenschutz / Privacy Policy