Weiterleitung für Modul RFC Fehlerhaft.



  • Hallo zusammen,

    ich arbeite nun seit einigen Stunden an einem Problem rum welches ich nicht gelöst bekommen.

    Hier Daten zur Umgebung

    Ich habe für jeden vHost einen entsprechende site im Apache angelegt und leute Anfragen auf Port 80 auf 443 um.
    i-doit Version -> i-doit 1.5.4 PRO
    System overview & Config Check -> Alles OK
    RFC Modul -> 1.0.6 (habe aber auch alle anderen probiert)

    .htaccess in idoit www Ordner
    <ifmodule mod_rewrite.c="">RewriteEngine On

    # security rules
            RewriteRule .svn/ - [F]
            RewriteRule ^controller$ - [F]
            RewriteRule ^(INSTALL|UPDATE|checkmk_transfer.sh|idoit-rights.sh|import|mandator|updatecheck)$ - [F]

    # favicon rewrite
        RewriteRule favicon.ico$ images/favicon.ico [L]

    # base rewriting
            RewriteCond %{REQUEST_FILENAME} !-l
            RewriteCond %{REQUEST_FILENAME} !-f
            RewriteCond %{REQUEST_FILENAME} !-d
            RewriteRule .* index.php [L,QSA]</ifmodule>

    .htaccess Datei im rfc Ordner
    Options Indexes FollowSymLinks

    Turn on URL rewriting

    RewriteEngine On

    Installation directory

    RewriteBase /rfc/

    Protect hidden files from being viewed

    <files .*="">Order Deny,Allow
            Deny From All</files>

    Protect application and system files from being viewed

    RewriteRule ^(?:application|modules|system)\b.* index.php/$0 [L]

    Allow any files or directories that exist to be displayed directly

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d

    Rewrite all other URLs to index.php/URL

    RewriteRule .* index.php/$0 [PT]

    Inhalte der RFC Bootstrap.php
    /**

    • Initialize Kohana, setting the default options.
    • The following options are available:
      • string  base_url    path, and optionally domain, of your application  NULL
      • string  index_file  name of your index file, usually "index.php"      index.php
      • string  charset    internal character set used for input and output  utf-8
      • string  cache_dir  set the internal cache directory                  APPPATH/cache
      • boolean  errors      enable or disable error handling                  TRUE
      • boolean  profile    enable or disable internal profiling              TRUE
      • boolean  caching    enable or disable internal caching                FALSE
        /
        Kohana::init(array(
        /
        *
            'base_url'  => '/rfc/',
        */
            'base_url'  => str_replace('index.php', '/', @$_SERVER['SCRIPT_NAME']),
            'index_file' => '',
            'errors' => false
        ));
        Wenn ich das RFC Modul aufrufe schlage ich immer auf eine Fehlgeleitete Seite auf.

    Die Weiterleitung hat als Ziel:

    https://idoit.<meinedomain>.derfc/frontend?destination=

    Es fehlt dort das Slash in der URL.

    Lade ich die Seite über den direkten Aufruf der index.php

    https://idoit.<meinedomain>.de/rfc/index.php

    Sehe ich die RFC Seite aber falsch. Es fehlt der Aufbau, Bilder, Inhalte. Die Base URL ist falsch so dass einfach alles nicht geladen wird.

    Ich habe die .htaccess Datei in allen Ordner schon deaktiviert. Schon an der bootstrap rumgespielt. Ich finde das Problem nicht.

    Auch hier im Forum gibt es einige Artikel zum RFC Modul, welche mir aber leider nicht geholfen haben:

    Vielleicht kann mir jemand helfen bei der Suche nach der Quelle der "falschen" Weiterleitung?
    Gruß
    Philipp</meinedomain></meinedomain>


 


Datenschutz / Privacy Policy