Problem with fresh i-doit installation and object relations



  • Im just started testing i-doit, trial and tried to add simple relation between two object. I added 2 objects (servers) and tried add relation between then to see how it works, click save and error occurs:

    CMDB Error: Database error : Query error: 'SELECT isys_cats_relation_details_list__id FROM isys_cats_relation_details_list WHERE isys_cats_relation_details_list__isys_obj__id = 34;':
    Table 'idoit_data.isys_cats_relation_details_list' doesn't exist

    Things what I have done is added 2 servers to infrastructure (server01 and server02). Then Extras -> CMDB -> Relationship, try to add new relation, object 1 (server01) has dependency to Object 2 (server02), save and error occurs. I checked my mysql idoit_data db and there is no isys_cats_relation_details_list table. Why table doesn't exists?

    I followed i-doit own installation manual and installed to my own operation system (Centos7), installed LAMP, downloaded i-doit zip file and fresh installation nothing extra configurations.


  • i-doIT Team

    Hi,

    Thanks for your post! I can confirm this behavior in i-doit pro 1.8 and filed a bug.

    Greetings,
    Benjamin



  • Ok

    Can I do something about it. I would like to create object relations.


  • i-doIT Team

    This issue is going to be resolved in the next i-doit pro version 1.8.1. It will be released within the next weeks.


 


Datenschutz / Privacy Policy