LDAP Anmeldung



  • Yep, mit der Version 0.9.7-1 funktioniert es wie erwartet.

    Besten Dank!

    Gruß
    mg



  • Hallo,

    gibt es dieses Problem mit den Sonderzeichen noch ? - Ich habe mit Version 0.9.9-3 getestet, da geht es nicht.
    Wird an der LDAP-Integration noch weiter gearbeitet ? Ich persönlich empfinde diese als sehr wichtig - für mich ist das ein K.O Kriterium für die Auswahl/Einsatz von Software in unserem Unternehmen.

    Mfg.
    Thomas Süß

    @ds:

    Tatsächlich, ein Login mit Sonderzeichen ist allgemein nicht möglich. Wir werden uns drum kümmern
    Danke für den Hinweis



  • Das Problem ist zur nächsten Version behoben



  • Ldap Version i-doit - 0.9.9-3 vs 0.9.9-4

    Gab es zwischen beiden Versionen Änderungen am Ldap-Modul/Schnittstelle ?

    Folgendes "Phänomen" habe ich hier:
    Ich habe auf einem Linux-Server (Ubuntu-8.04 LTS) beide i-doit Versionen installiert (die 0.9.9-4 zur Evaluierung), mit der 0.9.9.-3 habe ich das Login über LDAP Konfiguriert, das funktioniert, ebenfalls der Import der aus dem Active-Directory ausgelesenen Benutzer.

    In Version 0.9.9.4 funktioniert der Login per LDAP nicht, trotz genau gleicher Konfiguration. Melde ich mich erstmalig peer LDAP an, wechselt das Loginfenster (also ich kann nun den Mandanten auswählen) - was ja heist das bis dahin alles ok ist, klicke ich auf weiter erscheint "Invalid Passwort"  - bei weiteren Anmeldeversuchen erscheint sofort "Invalid username or password" - was nicht stimmt, in Version 0.9.9.3 funktioniert es ja. Im LDAP-Debug Log sehe ich folgendes:

    Hier erscheint sofort die Fehlermeldung: "Invalid Passwort"

    administrator@kisa-intranet:/var/www/i-doitos$ sudo mc
    Datei: ldap_debug.txt   Spalte 0           104849 Bytes                                                                              96%
    2011-02-01 10:49:07 ldap: Creating new ldap-library connection to: leipzig-dc1.leipzig.kisa.local:389, user: Administrator
    2011-02-01 10:49:09 ldap: Connected to leipzig-dc1.leipzig.kisa.local
    2011-02-01 10:49:09 ldap: Trying to auth with DN: CN=Süß, Thomas,OU=Systemtechnik-DD,OU=Kompetenzcenter,OU=_Benutzer,DC=dresden,DC=kisa,
    DC=local
    2011-02-01 10:49:09 ldap: CN=Süß, Thomas,OU=Systemtechnik-DD,OU=Kompetenzcenter,OU=_Benutzer,DC=dresden,DC=kisa,DC=local / Suess auth fa
    iled.  LDAP-Result: Invalid credentials

    Die erscheint nachdem der User in i-doit gelöscht/gepurgt wurde….

    2011-02-01 10:49:10 ldap: ----------------------------------------------------------------------------------------------
    2011-02-01 10:49:10 ldap: Creating new ldap-library connection to: dresden-dc3.dresden.kisa.local:389, user: administrator
    2011-02-01 10:49:10 ldap: Connected to dresden-dc3.dresden.kisa.local
    2011-02-01 10:49:10 ldap: Searching for username: Suess
    2011-02-01 10:49:10 ldap: Getting user(s) using filter: (&(objectClass=user)(sAMAccountName=Suess)) in search-path: OU=Kompetenzcenter,O
    U=_Benutzer,DC=dresden,DC=kisa,DC=local
    2011-02-01 10:49:10 ldap: Found DN: CN=Süß, Thomas,OU=Systemtechnik-DD,OU=Kompetenzcenter,OU=_Benutzer,DC=dresden,DC=kisa,DC=local. Try
    ing to login with it.
    2011-02-01 10:49:10 ldap: Auth successfull (CN=Süß, Thomas,OU=Systemtechnik-DD,OU=Kompetenzcenter,OU=_Benutzer,DC=dresden,DC=kisa,DC=lo
    cal).

    Ich vermute das in der aktuellen Version das auslesen der Gruppen defekt ist, die Konfiguration ist in beiden Versionen komplett Identisch - wie gesagt 0.9.9.3 funktioniert - 0.9.9.4 nicht....

    Einlesen der Benutzer aus dem Active Directory mittels "sudo php /var/www/idoit/controller.php -v -m ldap sync" funktioniert in beiden Versionen problemlos.

    Mit freundlichen Grüßen

    Thomas Süß
    Systemtechniker Kompetenz-Center Systemtechnik
    KISA - Kommunale Informationsverarbeitung Sachsen
    Geschäftsstelle Dresden-Blasewitz
    Käthe-Kollwitz-Ufer 88, 01309 Dresden
    TEL:  0351 6569411-612
    TEL:  0151 55038-367
    FAX:  0351 6569411-1102
    E-Mail: thomas.suess@kisa.it
    Internet: www.kisa.it



  • Es könnte an dem Umlaut im Namen liegen. Ist im Passwort auch ein Umlaut enthalten?



  • Der Windows Logon Name ist "suess" - damit funktioniert es in Version 0.9.9-3 - Im Passwort ist tatsächlich ein "!" enthalten, ich habe daraufhin einen Benutzer "idoittest" angelegt - PW "047Idoit" - dann bekomme ich im LDAP ein "Invalid Creditials" - also daran liegt es nicht (leider)….

    Gruss
    Thomas

    Edit:
    Im LDAP-Debug Log bekomme ich folgendes:

    2011-02-01 11:20:39 ldap: LDAP Module launched for mandator: idoit_data
    2011-02-01 11:20:39 ldap: Found 5 configured LDAP Servers.
    2011-02-01 11:20:39 ldap: 1: dresden-dc3.dresden.kisa.local (OU=Kompetenzcenter,OU=_Benutzer,DC=dresden,DC=kisa,DC=local)
    2011-02-01 11:20:39 ldap: ----------------------------------------------------------------------------------------------
    2011-02-01 11:20:39 ldap: Creating new ldap-library connection to: dresden-dc3.dresden.kisa.local:389, user: administrator
    2011-02-01 11:20:39 ldap: Connected to dresden-dc3.dresden.kisa.local
    2011-02-01 11:20:39 ldap: Searching for username: idoittest
    2011-02-01 11:20:39 ldap: Getting user(s) using filter: (&(objectClass=user)(sAMAccountName=idoittest)) in search-path: OU=Kompetenzcenter,OU=_Benutzer
    ,DC=dresden,DC=kisa,DC=local
    2011-02-01 11:20:39 ldap: Found DN: CN=Tester, Max,OU=Systemtechnik-DD,OU=Kompetenzcenter,OU=_Benutzer,DC=dresden,DC=kisa,DC=local. Trying to login wi
    th it.
    2011-02-01 11:20:39 ldap: Auth successfull (CN=Tester, Max,OU=Systemtechnik-DD,OU=Kompetenzcenter,OU=_Benutzer,DC=dresden,DC=kisa,DC=local).
    2011-02-01 11:20:39 ldap: User account created. User-ID: 124
    2011-02-01 11:20:39 ldap: isys_exception_database : Query error: 'INSERT INTO isys_person_2_group SET isys_person_2_group__isys_obj__id__person = '124'
    , isys_person_2_group__isys_obj__id__group = '14';':
    Cannot add or update a child row: a foreign key constraint fails (idoit_data/isys_person_2_group, CONSTRAINT isys_person_2_group_ibfk_1 FOREIGN KEY
    (isys_person_2_group__isys_obj__id__person) REFERENCES isys_obj (isys_obj__id) ON DELETE CASCADE ON )

    Hat jemand eine Idee dazu ? - Gibt es eine Möglichkeit den LDAP-Softwarestand/Module von 0.9.9.3 ind 0.9.9.4 zu kopieren (auch wenn das nur ein Workaround ist).

    @ds:

    Es könnte an dem Umlaut im Namen liegen. Ist im Passwort auch ein Umlaut enthalten?



  • Hat jemand eine Idee dazu ? - wie gesagt, die LDAP-Sache ist wichtig, die Integration ins AD ist ein wichtiges Kriterium für oder gegen die Anschaffung einer Software. Natürlich geht es auch ohne, aber es ist eben auch schön sich nicht 200 verschiedene Passwörter merken zu müssen. Ansonsten macht i-doit einen guten Eindruck !

    Gruß,
    Thomas



  • Push - auch wenn ich das ungern machen. Gehen wir anders an das "Problem" hat jemand mit Version 0.9.9-4 eine Anmeldung über LDAP gegen das Active-Directory eines Windows 2003 Servers hinbekommen und kann sich hier mit mir austauschen ?

    Ich poste hier im Laufe des Tages meine Konfiguration nochmal…

    Thomas



  • Wir haben die Version 0.9.9-4 und lassen gegen einen Windows Server 2008 authentifizieren. In der Konfig ist nichts Magisches. Welchen Teil soll ich mal posten?



  • Es koennte sein das du nicht den aktuellsten Stand des LDAP Moduls hast, ladt dir mal die 0.9.9-4 Installationsversion herunter und kopier die Datei src/classes/modules/isys_module_ldap.class.php dort heraus und ersetze sie mit der Datei in deiner Installation


Log in to reply
 


Datenschutz / Privacy Policy