I-doIT mit Linux SuSe 9.3



  • Hallo Zusammen,
    funktioniert I-doIT auch unter der SuSE 9.3??

    Vielen Dank für eure Hilfe

    Setting



  • Ich habe es jetzt einfach probiert, und soweit hat es auch funktioniert!

    Habe mit einen Browser //Host/i-doit/installer aufgerufen, und dann die konfiguration vorgenommen…
    Danach kam dann die Meldung man solle noch die config.inc.php anpassen!

    Aber wo finde ich die config.inc.php???

    Danke für die Hilfe

    Setting



  • Hallo Zusammen,

    erstmal bitte ich euch mir zu helfen, langsam wird es nämlich echt heiß! Ich komm einfach nicht weiter…

    Ich habe jetzt eine SuSE Linux 9.1 installiert mit php 4.3.11, apache2, mysql 4.0.18 mit den in der INstallationsanleitung angegebenen zusätzlichen Packeten.....

    Die automatische Installation von i-doit funktioniert nicht, da kommt eine Error-Meldung:ERROR: Es wurde kein Apache HTTP Server gefunden oder angegeben, die automatische Installation wird beendet. Bitte konsultieren Sie die Installationsanleitung 'INSTALL'. Der Befehl 'apache', 'apache2' oder 'httpd' muss sich fuer die automatische Installation in einem der Standardsuchpfade befinden.

    Bei der manuellen installation kopiere ich die entpackten i-doit - Files in das Webverzeichnis /srv/www/htdocs/i-doit und führe in einem Browser die install.php aus. Das funktioniert auch wunderbar, bis die Meldung kommt, man solle in der config.ink.php das Basisverzeichnis anpassen!
    Ich finde keine config.php.ink, und wenn ich auf "Bitte hier klicken um zum i-doit-System zu kommen, gelange ich wieder zum beginn der einstellungen....

    Bitte helft mir, bin wirklich ratlos....

    Gruß
    Setting



  • natürlich config.inc.php



  • Hi
    das klingt für mich nach einem rechteproblem, hat der user unter dem apache läuft schreibrecjte im i-doit dir ?



  • Habe die Berechtigungen geändert… hat auch soweit funktioniert....

    Jetzt kommt aber leider folgende Fehlermeldung:

    Fatal error: Call to undefined function: session_id() in /srv/www/htdocs/i-doit/config_session.inc.php on line 16

    Bitte helft mir, bin langsam wirklich ein bisschen verzweifelt...

    Vielen Dank für eure Hilfe

    Setting

    PS: Habe es auch schon per mail an support@i-doit.de geschickt....



  • Das gleiche Problem mit dem install.sh hatte ich auch.

    :!: Das liegt daran, dass der Befehl apache2 -V in der Version nicht existiert.
    Also muss man im install.sh die Zeile mit dem apache2 -V aufruf in apache2ctl -V abändern. Danach geht es weiter.

    :?: Allerdings habe ich weitere Probleme bei meiner Installation.
    Rufe ich die Seite http://servername/i-doit/ wird die /installer/index.php geladen. Obwohl ich die richtigen Parameter eingebe (und automatische Installation), bleibt das PHP-Skript einfach stehen (nachdem ich Parameter prüfen gewählt habe und alles grün zu sein scheint) - es passiert nix - kein Fehler oder so …

    Vielleicht weiss hier jemand weiter!?
    Ich würde ja auch die Parameter händisch eintragen, wenn ich nur schon wüsste wo…

    Es wäre wichtig, da wir uns hier sonst wieder umorientieren würden, obwohl wir die Lösung (Test war unter Windows) ganz klasse fanden. Aber wenn ich das Ding diese Woche nicht zu Fliegen kriege ...

    :oops:



  • Hi,

    hast du die MySQL-Extension mitinstalliert (diese ist normalerweise built-in) und funktioniert diese (phpinfo() gibt genauere Infos)?
    Sind auf das Verzeichnis, wo i-doIT installiert wird, die richtigen Rechte gesetzt (der Apachebenutzer braucht initial Schreibrechte)?

    Desweiteren ist es ganz wichtig, die Sessionlibrary mit in PHP installiert zu haben (http://de2.php.net/manual/en/ref.session.php). Der PHP-Interpreter darf demnach nicht mit –disable-session kompiliert worden sein.



  • Zunächst mal vielen Dank für die schnelle Antwort.
    Habe gestern den ganzen Tag experimentiert.
    An meinem Problem hat sich noch nichts geändert.

    Also die Rechte stimmen.
    phpinfo() sagt zwar was von –without mysql - aber das gleube ich deshalb nicht da ja auch phpMyAdmin funktioniert (zur admin der mysql-db).

    Wie auch immer stamdardmaessig sollte mysql gehen. Würde auch keinen Sinn machen die php-mysql extension mit apache und mysql ueber yast zu installieren, wenn es danach nicht klappt - oder?

    Hab' noch angefangen eine neue PHP-Version 4.3.11 --with mysql zu kompilieren.

    Allerdings ist heute um 11 Kriesensitzung - wir werden dann vielleicht unter Windows installieren oder was anderes verwenden.

    jk



  • …wie gesagt habe extra noch eine neue PHP 4.3.11 gebaut und zwar --with mysql.

    Nach dem Neustart sagt die Konsole:
    php -v
    PHP 4.3.11 (cgi)

    Wenn ich allerdings phpinfo() nehme sagt er, dass er die Version 4.3.8 verwendet!

    WIE KANN DAS SEIN?

    Wie bereits erwähnt, da PHPMyAdmin funktioniert glaube ich momentan nicht an fehlende mysql extensions.

    Ach ja das session modul ist auch geladen.

    Ich bin ratlos und soll den Rechner jetzt dann Ende der Woche platt machen.



  • könntest du den output von phpinfo(); einmal spiechern und mir mailen?



  • Hi,

    bevor hier fatale Missverständnisse auftreten: Unter SuSE wird die mySQL Extension zwar mitinstalliert, aber nicht in PHP mit reinkompiliert und auch nicht in der php.ini als zu ladende Extension eingetragen. Das was phpMyAdmin macht, ist mit Hilfe der Funktion dl(..) die mysql-Extension dynamisch nachzuladen, deswegen funktioniert es auch. Folglich muss in der php.ini die mySQL Extension als zu Laden eingetragen werden (mit extension=libmysql.so oder so ähnlich).



  • Ja - genau das war das Problem…

    Die Extensions waren nicht in der PHP.ini eingetragen - danach hat es gleich funktioniert.

    Man kann wohl auch über Yast/Netzwerdienste/http-server/extensions oder so ähnlich die Module "enable"n

    Danke nochmal für die prompte und nette Unterstützung



  • @Setting:

    Jetzt kommt aber leider folgende Fehlermeldung:

    Fatal error: Call to undefined function: session_id() in /srv/www/htdocs/i-doit/config_session.inc.php on line 16

    Habe wie "leokirch" geschrieben die install.sh geändert, so konnte ich auch die automatische Installation laufen lassen.
    Danach habe ich wieder die Konfiguration durchgeführt (http://localhost/i-doit/installer/index.php), bekomme aber wenn ich auf den weiterführenden Link klicke immernoch die oben genannte Meldung!

    Was kann ich tun?

    Vielen Dank für die Hilfe
    Setting



  • @Setting:

    Jetzt kommt aber leider folgende Fehlermeldung:

    Fatal error: Call to undefined function: session_id() in /srv/www/htdocs/i-doit/config_session.inc.php on line 16

    Ich bin nicht vom Support und habe nur eine Vermutung.
    Schau mal welche PHP-Module in der /etc/php.ini geladen werden.

    [extension section]
    extension=session.so

    Einige davon sind Voraussetzung "php4-ldap, php4-mysql und …"



  • Das ist der Auszug aus der php.ini

    [extension section]
    extension=zlib.so
    extension=recode.so
    extension=bz2.so
    extension=mcrypt.so
    extension=gd.so
    extension=mysql.so
    extension=ldap.so
    ; end of extension section

    Sind das die richtigen u. alle?

    Danke für die Hilfe!

    Setting



  • Was ist mit der Session Library?

    extension=session.so
    

    Oder ist das schon in PHP mit reinkompiliert?



  • @aw:

    Was ist mit der Session Library?

    extension=session.so
    

    Oder ist das schon in PHP mit reinkompiliert?

    Habe diesen Eintrag in der php.ini ergänzt. (das hast du gemeint, oder?)

    Geht noch nicht…

    Gruß
    Setting



  • Wie gesagt, wenn die Funktion session_id() nicht gefunden wurde, ist die Session Handling Library nicht verfügbar. Das kann entweder an einer nicht geladenen Extension liegen (wie schon in meiner vorherigen Antwort beschrieben), an einer nicht vorhandenen session.so oder dass das Session Handling nicht in PHP mit reinkompiliert wurde.

    Hast du den Apache übrigens nach der Änderung neugestartet?

    Unter SuSe muss man unter YAST sicherlich das Sessionhandling nachinstallieren.

    Ansonsten wüsste ich auch nicht weiter, ich kann dich nur noch auf die PHP Dokumentation verweisen …



  • Übrigens, ich glaube das RPM-Package heisst php4-session :idea:


Log in to reply
 


Datenschutz / Privacy Policy