LDAP Auth failed bei Username = uid



  • Hallo,

    ich versuche gerade bei idoit 0.9.9-9 Pro eine LDAP Authentifizierung mit der uid als Username einzurichten.
    Ich bekomme jedoch die Meldung: Invalid username or password!
    Folgendes steht im Debugfile:

    2012-06-25 10:06:23 ldap: *** LDAP Auth failed. (false)
    2012-06-25 10:06:53 ldap: LDAP Module launched for mandator: idoit_data
    2012-06-25 10:06:53 ldap: Found 1 configured LDAP Servers.
    2012-06-25 10:06:53 ldap: 1: xxx (ou=users,ou=xxx,o=xxx,c=de)
    2012-06-25 10:06:53 ldap: ----------------------------------------------------------------------------------------------
    2012-06-25 10:06:53 ldap: Creating new ldap-library connection to: xxx:389, user: cn=admin,o=xxx,c=de
    2012-06-25 10:06:53 ldap: Connected to xxx
    2012-06-25 10:06:53 ldap: Searching for username: pborowy
    2012-06-25 10:06:53 ldap: Getting user(s) using filter: (&(objectClass=person)(uid=pborowy)) in search-path: ou=users,ou=idoit,o=xxx,c=de
    2012-06-25 10:06:53 ldap: Found DN: cn=xxx,ou=Users,ou=IdoIT,o=xxx,c=DE. Trying to login with it.
    2012-06-25 10:06:53 ldap: ** Auth failed.
    

    Wenn ich den Username jedoch auf cn mappe, funktioniert die Anmeldung!

    2012-06-25 09:53:18 ldap: LDAP Module launched for mandator: idoit_data
    2012-06-25 09:53:18 ldap: Found 1 configured LDAP Servers.
    2012-06-25 09:53:18 ldap: 1: xxx (ou=users,ou=idoit,o=xxx,c=de)
    2012-06-25 09:53:18 ldap: ----------------------------------------------------------------------------------------------
    2012-06-25 09:53:18 ldap: Creating new ldap-library connection to: xxx:389, user: cn=admin,o=xxx,c=de
    2012-06-25 09:53:18 ldap: Connected to xxx
    2012-06-25 09:53:18 ldap: Trying to auth with DN: cn=xxx,ou=Users,ou=IdoIT,o=xxx,c=DE
    2012-06-25 09:53:18 ldap:  + cn=xxx,ou=Users,ou=IdoIT,o=xxx,c=DE / xxx authenticated.
    2012-06-25 09:53:18 ldap: Getting user(s) using filter: (&(objectClass=person)(cn=xxx)) in search-path: ou=users,ou=idoit,o=xxx,c=de
    2012-06-25 09:53:18 ldap: Getting groups of cn=xxx,ou=Users,ou=IdoIT,o=xxx,c=DE (Servertype: Open LDAP)
    2012-06-25 09:53:18 ldap:  Attention: OpenLDAP connections are currently experimental!
    2012-06-25 09:53:18 ldap:  search() ou=groups,ou=idoit,o=xxx,c=de (Filter: (member=cn=xxx,ou=Users,ou=IdoIT,o=xxx,c=DE)): 1
    2012-06-25 09:53:18 ldap:  ** i-doit group pendant for "AllUsers" found: LDAP-Test
    2012-06-25 09:53:18 ldap: Syncing groups..
    2012-06-25 09:53:18 ldap:  Attached user(27) to group: LDAP-Test
    2012-06-25 09:53:18 ldap: ----------------------------------------------------------------------------------------------
    2012-06-25 09:53:18 ldap: --- LDAP-Login succeeded. Granting access..
    

    Vielen Dank schonmal für die Hilfe!



  • Hi,

    gibt es eine Lösung für das Problem? Ich habe das selbe Problem mit der Version 0.9.9-7.

    Tschau
    Tobias


 


Datenschutz / Privacy Policy