*gelöst* Anmeldung über LDAP (AD) an i-doit trotz Auth successfull nicht möglich



  • Hallo!

    Ich habe ein Problem mit der Anmeldung am i-doit mit ActiveDirectory-Benutzern.

    Trotz erfolgreicher Authentifizierung gegen AD kann ich mich mit den Daten nicht am i-doit anmelden. (Invalid username or Password)

    Auszug aus ldap_debug.txt:

    2013-02-12 15:23:07 ldap: Creating new ldap-library connection to: DC.Some.Domain:389, user: CN=SomeUser,CN=Users,DC=Some,DC=Domain
    2013-02-12 15:23:07 ldap: Connected to DC.Some.Domain
    2013-02-12 15:23:07 ldap: Searching for username: steffens
    2013-02-12 15:23:07 ldap: Getting user(s) using filter: (&(objectClass=user)(sAMAccountName=steffens)) in search-path: OU=Benutzer,DC=Some,DC=Domain
    2013-02-12 15:23:07 ldap: Found DN: CN=Steffen Schulz,OU=Techniker,OU=Benutzer,DC=Some,DC=Domain. Trying to login with it.
    2013-02-12 15:23:07 ldap: Auth successfull (CN=Steffen Schulz,OU=Techniker,OU=Benutzer,DC=Some,DC=Domain).

    Dieser Benutzer ist Mitglied der Domänenlokalen Gruppe DL_i-doit_Admins, und diese LDAP-Gruppe ist der i-doit-Gruppe Admins zugeordnet.

    i-doit: 0.9.9-7

    Gruß
    Steffen



  • HAllo!

    Mein Problem habe ich zwar noch nicht lösen können, aber vielleicht bin ich ja der Ursache auf der Spur.

    Die OU-Struktur im AD hat sich geändert. Allerdings steht im i-doit beim Benutzer noch der alte Pfad drin. Leider kann man den nicht einfach per "Editieren" bearbeiten, und die entsprechende Tabelle habe ich leider auch noch nicht gefunden, um diesen Eintrag dort von Hand anzupassen.

    Der Wert im i-doit:
    CN=Steffen Schulz,OU=Benutzer,OU=MeineFirma,DC=Some,DC=Domain

    Der Wert, mit dem der Login versucht wird:
    CN=Steffen Schulz,OU=Techniker,OU=Benutzer,DC=Some,DC=Domain

    Gruß
    Steffen



  • Hallo!

    Nach langer Zeit habe ich die Lösung dank eines ehem. Kollegen gefunden!
    Die eigentliche Ursache für das Problem des "nicht-anmelden-könnens" kenne ich leider nicht mehr, aber bei dem Versuch, dieses Problem zu beheben, habe ich irgendwann mal meinen im i-doit via LDAP-Login angelegten Benutzer gelöscht. In meiner Unerfahrenheit kannte ich die 3 Stufen des Löschens nicht (archivieren, löschen, endgültig löschen), und so lag der Benutzer die ganze Zeit im Archiv rum. Ergebnis: LDAP sagt "Daten OK", aber i-doit sagt "Benutzer archiviert!" und damit Login verweigert.
    Wir haben den Benutzer endgültig gelöscht (ja ich weiß, aus dem Archiv wiederherstellen hätte es auch getan…) und siehe da, Anmeldung war wieder möglich.

    Blöd war jetzt natürlich, das wir es nur ganz am Anfang mal ausprobiert hatten, ob sich mein Kollege anmelden konnte. Konnte er nicht, also das selbe Problem bei beiden und nie wieder mit seinem Account probiert. Das ursprüngliche Problem war schon längst behoben, ist nur nie aufgefallen, weil mein eigener Account im i-doit nicht mehr funktionierte....

    Gruß
    Steffen

    PS: Danke nchmal an Benjamin B. aus T.


Log in to reply
 


Datenschutz / Privacy Policy