RFC Modul - Internal Server Error



  • Hallo an alle,
    i-doit läuft soweit. Nun hatte ich das RFC Modul (in zip Datei, also ganz normal) installiert. Wenn ich es nun in i-doit versuche zu öffnen, bekomme ich einen "500 Internal Server Error". Auf dem Server läuft Apache/2.2.22 (Debian).
    In dem Apache ErrorLog hab ich dann folgendes gefunden:

    [alert] [client IP Adress] /var/www/i-doit/rfc/.htaccess: RewriteBase takes one argument, the base URL of the per-directory context, referer: http://localhost/i-doit/

    Ich hoffe jemand kann mit den Informationen etwas anfangen.
    Grüße



  • Hallo The.Man,

    die Fehlermeldung lässt darauf schließen das dein Server mit der mitgelieferten .htaccess Datei (zu finden unter "/var/www/i-doit/rfc/.htaccess") Probleme hat. Könntest du kurz beschreiben was in der Zeile mit "RewriteBase" zu sehen ist? Für gewöhnlich sollte da sowas stehen wie "/rfc/" o.Ä.

    Viele Grüße
    Leo



  • Hier der Inhalt der .htaccess Datei im Ordner /var/www/i-doit/rfc:

    Options Indexes FollowSymLinks

    Turn on URL rewriting

    RewriteEngine On

    Installation directory

    RewriteBase

    Protect hidden files from being viewed

    <files .*="">Order Deny,Allow
            Deny From All</files>

    Protect application and system files from being viewed

    RewriteRule ^(?:application|modules|system)\b.* index.php/$0 [L]

    Allow any files or directories that exist to be displayed directly

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d

    Rewrite all other URLs to index.php/URL

    RewriteRule .* index.php/$0 [PT]

    In der Zeile mit RewriteBase steht nichts.

    Grüße



  • Hallo Team,
    wenn ich in der .htaccess hinter dem "RewriteBase" /rfc/ eintrage oder /var/www/i-doit/rfc/ kommt nun folgender Fehler, wenn ich in i-doit das RFC Modul öffne:

    HTTP_Exception_404 [ 404 ]: The requested URL i-doit/rfc was not found on this server.

    SYSPATH/classes/kohana/request/client/internal.php [ 87 ]
    82
    83 try
    84 {
    85 if ( ! class_exists($prefix.$controller))
    86 {
    87 throw new HTTP_Exception_404('The requested URL :uri was not found on this server.',
    88 array(':uri' => $request->uri()));
    89 }
    90
    91 // Load the controller using reflection
    92 $class = new ReflectionClass($prefix.$controller);

    1. SYSPATH/classes/kohana/request/client.php [ 64 ] » Kohana_Request_Client_Internal->execute_request(arguments)
    59 public function execute(Request $request)
    60 {
    61 if ($this->_cache instanceof HTTP_Cache)
    62 return $this->_cache->execute($this, $request);
    63
    64 return $this->execute_request($request);
    65 }
    66
    67 /**
    68 * Processes the request passed to it and returns the response from
    69 * the URI resource identified.

    2. SYSPATH/classes/kohana/request.php [ 1138 ] » Kohana_Request_Client->execute(arguments)
    1133 throw new Request_Exception('Unable to execute :uri without a Kohana_Request_Client', array(
    1134 ':uri' => $this->_uri,
    1135 ));
    1136 }
    1137
    1138 return $this->_client->execute($this);
    1139 }
    1140
    1141 /**
    1142 * Returns whether this request is the initial request Kohana received.
    1143 * Can be used to test for sub requests.

    3. DOCROOT/index.php [ 113 ] » Kohana_Request->execute()
    108 /**
    109  * Execute the main request. A source of the URI can be passed, eg: $_SERVER['PATH_INFO'].
    110  * If no source is specified, the URI will be automatically detected.
    111  */
    112 echo Request::factory()
    113 ->execute()
    114 ->send_headers()
    115 ->body();

    Jemand eine Idee?

    Grüße
    The.Man



  • Hallo The.Man,

    ich habe eine Vermutung an der es liegen könnte. Innerhalb von RewriteBase kann ruhig der absolute Pfad stehen - Dieser muss aber auch an einer anderen Stelle eingetragen werden: /var/www/i-doit/rfc/application/bootstrap.php etwa auf Zeile 82 gibt es folgendes Konstrukt:

    /**
     * Initialize Kohana, setting the default options.
     *
     * The following options are available:
     *
     * - string   base_url    path, and optionally domain, of your application   NULL
     * - string   index_file  name of your index file, usually "index.php"       index.php
     * - string   charset     internal character set used for input and output   utf-8
     * - string   cache_dir   set the internal cache directory                   APPPATH/cache
     * - boolean  errors      enable or disable error handling                   TRUE
     * - boolean  profile     enable or disable internal profiling               TRUE
     * - boolean  caching     enable or disable internal caching                 FALSE
     */
    Kohana::init(array(
        'base_url'   => '',
        'index_file' => '',
    ));
    ```Kannst du bitte unter "base_url" ebenfalls deinen Pfad reinschreiben (einfach mal Relativ und Absolut ausprobieren)? Es scheint so, als wäre bei der RFC Modul-Installation etwas schief gelaufen und deine Pfade wurden nicht korrekt gesetzt.
    
    Viele Grüße
    Leo

Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.