Primäre IP Adresse -> Listeneditierung klappt nicht



  • Hallo,

    beim Import von OCS wurde  leider die falsche IP Adresse als Primär ([Ja]) definiert. Die IP Adresse welche per DHCP kommt, soll primär sein, während die statisch definierte lediglich nur für diesen Host existiert (Crossover Kabel). Nun habe ich bei 105 Clients über die Listeneditierung aus dem Ja ein Nein gemacht, und aus dem Nein ein Ja. Nach dem Speichern durfte ich feststellen, dass alle Änderungen nicht übernommen wurden, weshalb nun schon meine Finger bluten. Es wird wieder auf den alten Wert gesetzt. Ist das nun ein Bug? Oder mache ich da etwas falsch? Wie kann ich das Problem eleganter lösen?

    cu denny


  • i-doit Kenner

    Hallo denny,

    ich habe das gleiche bei mir ausprobiert, es funktioniert einwandfrei! Meine erste Vermutung war, dass Du irgendwas falsch machst. Allerdings ist das Verhalten, welches Du beschreibst, in der Demo nachzustellen… (Jetzt wunder ich mich, dass es bei mir funktioniert :D)
    Scheint also tatsaechlich ein Bug zu sein, wobei ich bisher noch nicht herausgefunden habe, was die Ursache dafuer sein koennte...

    Ein Loesungsvorschlag meinerseits:

    Wie waers mit einem mysql-Statement, welches Du einmal ueber die betroffenen Server (also alle) drueber buegelst, damit Du das glatt hast?

    Gruss,
    jkondek



  • hi jkondek,

    das habe ich schon leicht vermutet, dass dies ein Fehler von 1.4 (18300) ist. Ich werde da gleich nochmal einen Bug Report absetzen.

    Danke für das Verifizieren.


  • i-doit Kenner

    Hallo denny,

    so wuerde ich das nicht nennen. Ich habe die gleiche Version im Einsatz wie die Demo ist und bei mir funktioniert die Listeneditierung.

    Hast Du es denn jetzt ueber mysql glatt gezogen?

    Gruss,
    jkondek


  • i-doit Kenner

    Hallo denny,

    wie sieht es bei Dir mit suhosin aus? Ist das bei Dir installiert?

    In der Demo ist mir folgende Meldung aufgefallen:

    • You should disable the php extension suhosin in order to use multiedit properly.

    Eventuell hat es damit etwas auf sich?

    Gruss,
    jkondek



  • hi,

    existiert auf den Debian Rechner nicht.

    cu denny


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.