Open1.4 und anscheinend Fehlermeldung wg. php-suhosin-patch



  • Hallo,
    wir hatten bisher die open-Version 0.9 im test und abei keine Problemem mit der Installation. ich habe jetzt die Open-Version 1.4.2 heruntergeladen und wollte diese installieren. Allerdings erhalte ich beim Aufruf der index.php- Seite eine leeere Seite im Browser zurück. Im errorlog des Apache-Webserver findet sich dazu folgende Zeile:

    [Fri Aug 15 10:42:15 2014] [notice] Apache/2.2.12 (Linux/SUSE) mod_ssl/2.2.12 OpenSSL/0.9.8j-fips PHP/5.2.14 with Suhosin-Patch configured – resuming normal operations
    [Fri Aug 15 10:55:58 2014] [error] [client xxx.xxx.xxx.xxx] ALERT - possible memory corruption detected - unknown Hashtable destructor (attacker 'xxx.xxx.xxx.xxx', file '/srv/www/htdocs/idoit14/index.php')

    Nach meinen Recherchen im Internet scheint das mit dem suhosin-Patch von php in Verbindung zu stehen.
    Was kann ich jetzt tun um die Installation durchführen zu können.
    An der Installation des Apache möchte ich eigentlich nichts ändern, da unser Produktionssystem genauso aufgesetzt wurde.

    Mit freundlichen Grüssen
    Gerhard



  • Hallo Gerhard,

    die Suhosin Extension lässt sich üblicherweise einfach in der php.ini auskommentieren - an der Installation muss dafür nichts verändert werden. Der Apache muss nach der Anpassung an der php.ini lediglich neugestartet werden. Könntest du ausprobieren, ob das hilft?

    Viele Grüße
    Leo



  • Hallo,
    ich habe jetzt die suhosin-extensions in der ini-Datei deaktiviert. Das ändert aber leider nichts an der Fehlermeldung. Diese ist immer noch die gleiche. Die phpinfo-Funktion zeigt auch an das die suhosin-Extensions deaktiviert sind.
    So wie ich das bei der Recherche im Internet verstanden habe, sind auch nicht die suhosin-Extension, sondern der in php-eingebundene "patch" die Ursache.
    Anbei die entsprechende Ausgabe der phpinfo (Attachement).
    Ich habe jetzt darauf verzichtet die Ausgabe von phpinfo vor und nach der Deaktivierung der suhosin-Extensions anzuhängen, aber die suhosin-extensions sind definitiv ausgeschaltet. Daran kann es also nicht liegen.
    Ich kann leider auch nicht eingrenzen, ob der Fehler tatsächlich in der "index.php" liegt oder in einer den eingebunden php.Dateien.

    Leider also noch kein Forschritt, trotzdem Danke für die Anregung.

    Zur Ergänzung:im Einsatz ist Suse Linux Enterprise Server 11 SP3, mit apache2.2.12 und php 5.2.14.

    suhosin.png



  • Das Problem konnte behoben werden durch einen Update der php-Installation auf php5.3

    Danach lief dann auch die i-doit-Installation ohne Probleme durch.



  • Hallo Gerhard,

    es freut mich das es nun funktioniert! Kam bei der Installation keine Meldung, das die PHP Version zu alt ist?
    Wir setzen seit einiger Zeit PHP 5.3.x voraus.

    Viele Grüße
    Leo


 


Datenschutz / Privacy Policy