Session timeout set at 0 - can't login



  • Hi,

    I wanted to disable the session timeout, so I set the session timeout in system settings to 0, and now anytime I try to login it logs me out right away. Could you help me where to manually change this value? I looked in the var/www/html/idoit/src folder and found a session.time variable in the globals.inc.php file but it had a wrong value of 300 instead of 0 so I think it needs to be somewhere else.

    Any help is greatly appreciated.

    Regards,
    Patrik


  • i-doit Kenner

    Hello Patrik,

    you can set the session timeout in the system database, table isys_settings, key session.time.
    Check it out!

    Regards,
    jkondek



  • Ive tried to change the value on database session.time from 0 to 600, but the system ignores it. Im still getting error message "Your session timed out! (0 secs)"



  • @Montt:

    Ive tried to change the value on database session.time from 0 to 600, but the system ignores it. Im still getting error message "Your session timed out! (0 secs)"

    hi,

    have you solved this problem?

    Regards

    Philipp



  • Hello everyone,

    I am aghast at this bug, it's been around for much too long
    Anyway though
    I have the exact same issue, and no the DB hack does not help at all
    Any further ideas?

    Cheers

    linus



  • You can edit file src/globals.inc.php located in idoit webroot directory

    Find and comment string:
    //$g_config["sess_time"]      = isys_settings::get('session.time', 300);

    Temporary change it to:       
    $g_config["sess_time"]      = 900;

    After fixing timeout in GUI, you can delete temporary string and uncomment original

    (Tested on i-doit v. 1.4.8 )



  • Afaik,

    this does not apply for the recent versions of i-doit as the value for the session timeout
    has been defined in isys_application.class.php file which is located in
    src/classes/core/ from the web root.

    Best regards,

    Chekov



  • For all those, who have this problem, I found out the solution for the V4.1.15-8-default:

    1st: keep cool (it took me several coffees to calm down on this silly thing. If the value for timeout is 0, so the setting is off or the value is wrong. Why the heck, wasn't this catched by the program??)

    2nd: Login on your webserver, go into the i-doit-folder in the apache-webfiles (f.e. SuSE: /srv/www/htdocs/i-doit/…)
    3rd: find the globals.inc.php
    4th: open it with your favourite text-editor
    5th: find and copy the following line:

    
    $g_config["sess_time"]   = isys_settings::get('session.time', 300);
    
    

    6th: uncomment one of the original one with two slashes

    
    // $g_config["sess_time"]   = isys_settings::get('session.time', 300);
    
    

    7th: change the copied line:

    FROM

    
    $g_config["sess_time"]   = isys_settings::get('session.time', 300);
    
    

    TO

    
    $g_config["sess_time"]   = 900;
    
    

    8th: SAVE the file, but leave it open in your text-editor

    9th: Login to i-doit and change the value for Session Timeout in the Settings. 3600 (1 hour) might be a good value. Save the sessings

    10th: uncomment in the globals.inc.php

    
    // $g_config["sess_time"]   = isys_settings::get('session.time', 300);
    
    

    and comment the line

    
    $g_config["sess_time"]   = 900;
    
    

    That's it.


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.