WYSIWYG Editor und Images



  • Hallo,

    (I-doit 1.4.9 Pro)

    Es besteht die Möglichkeit Images in der Beschriebung zu hinterlegen via WYSIWYG-Editor.

    Eine Kontrolle nach der Hinterlegung des Images im Text über das Icon "Bild" zeigt im Source des Editors auch den richtigen Code - das Bild wird richtig in der Vorschau des Editors angezeigt.

    Doch nach dem Speichern verschwindet der Eintrag wieder.
    Ich versuchte via dem Speichernsymbol des Editors sowie über das Speichern des Datensatzes … kein Erfolg.

    Habe ich da ein Setting in der Konfig übersehen, oder ein Bug ?

    LG Stefan



  • Hallo Stefan,

    das "Problem" liegt weniger am WYSIWYG Editor sondern mehr an der Logik zum verarbeiten der Daten. Derzeit wird sehr streng auf bestimmte HTML Attribute geprüft die ggf. Schadcode enthalten können. Außerdem haben wir eine ganze Zeit lang sämtliche Attribute (alt, src, …) vor dem speichern entfernt.

    In den kommenden i-doit Releases haben wir den WYSIWYG Editor hier und da noch angepasst, sodass keine "nutzlosen" Funktionen dargestellt werden - zum Beispiel der von dir genannte "Speichern" Button. Dann sollte auch das speichern bzw. anzeigen von Bildern funktionieren.

    Bis dahin könntest du versuchen den Punkt "Dateneingabe bereinigen" (Verwaltung > CMDB Einstellungen > Allgemeine Einstellungen) auf "Nein" zu schalten.

    Viele Grüße
    Leo



  • Hallo,

    ja, danach habe ich gesucht.
    Danke hat funktioniert.

    LG Stefan


 


Datenschutz / Privacy Policy