Nach Update auf 1.5 Server Error 500



  • Hallo!

    Ich habe versucht, das Update 1.5 durchzuführen. Nach Schritt 5 (Keine Fehler) geht es nicht mehr weiter. Beim Versuch, idoit aufzurufen erscheint der Server Error 500.
    Meine Installation liegt auf /var/www/idoit. Im Apache-Log erscheint die Fehlermeldung
    /var/www/idoit/.htaccess: <ifmodule not="" allowed="" here="" <br="">In der Apachekonfiguration habe ich dann in der Directory-Sektion die Option Allowoverride All eingetragen und Apache neu gestartet.
    Die Fehlermeldung bleibt.

    Muss ich die .htaccess ändern?</ifmodule>



  • Hallo Kennerblick,

    was für eine Apache Version hast du denn im Einsatz? Eigentlich dürfte es mit der Syntax keinerlei Probleme geben.

    VG Leo



  • Server sagt:

    Server Version: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.6 mod_perl/2.0.8 Perl/



  • Hallo kennerblick,

    hast du probiert i-doit komplett ohne .htaccess Datei aufzurufen? Dadurch könnten wir herausfinden ob es wirklich an der Datei bzw. dessen Inhalt liegt. Für gewöhnlich sollte die Datei nicht verändert werden (müssen).
    Du könntest auch mal probieren die .htaccess Datei aus dem Setup Paket zu nehmen und in deinen Ordner zu schieben.

    VG Leo



  • Hallo Leo,

    wenn ich die .htaccess rausnehme, kann ich auf i-doit zugreifen. Das funktioniert nicht fehlerfrei, aber der Serverfehler 500 ist dann nicht da. Ich vermute, dass die htaccess während des Updates implementiert wird und deswegen das Update auch nicht alle Schritte durchlaufen kann.

    Beste Grüße - derzeit ohne i-doit 😞


  • i-doit Kenner

    Hallo kennerblick,

    wie sehen denn die Rechte auf die .htaccess aus? Mir ist aufgefallen, dass beim Ausfuehren des Scripts idoit-rights.sh die Rechte/User nicht auf versteckte Dateien uebertragen werden. Vielleicht ist das hier so ein Fall?

    Gruss,
    jkondek



  • Eigentümer ist www-data, Grupper www-data
    Leserechte für jeden, Schreibrechte für Eigentümer
    644

    Beste Grüße



  • Ich habe heute das Update der 1.5.5 gemacht, dabei ist mir auch der apache mit http 500 um die Ohren geflogen:

    
    idoit/.htaccess: Option FollowSymlinks not allowed here
    idoit/src/.htaccess: Option FollowSymlinks not allowed here
    
    

    Grund, Apache-Config, die ein Limit

    
                    AllowOverride AuthConfig FileInfo Indexes Limit Options=Indexes,SymLinksIfOwnerMatch
    
    

    Sollte auf jedem Webserver aus Sicherheitsgründen gesetzt sein. Vgl: http://blog.jonaspasche.com/2014/07/11/followsymlinks-vs-symlinksifownermatch/


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.