Update von Version 1.4.9 auf 1.5.x



  • Hallo zusammen,

    ich versuche eine ältere Version zu aktualisieren und stoße auf etwas Widerstand. Habe wie beschrieben das updates-Verzeichnis in den Ordner htdocs/idoit kopiert und über den Pfad http://localhost/idoit/updates den Updatevorgang gestartet. Erhalte im nachfolgenden Fenster nur Hinweise, einer davon (You should set post_max_size to at least 128M in order to update i-doit.).
    Habe auch schon den Pfad in der php.ini entsprechend angepasst, scheint aber nicht zu interessieren, die Meldung kommt immer noch. Ein Update ist somit nicht möglich. Woran könnte es denn scheitern.
    Vielen Dank für Hilfe!

    Gruß
    Andreas
    idoit_update.jpg


  • i-doit Kenner

    Hallo Andreas,

    Habe auch schon den Pfad in der php.ini entsprechend angepasst

    Was meinst Du damit? Dass Du die post_max_size auf den benoetigten Wert erhoeht hast?
    Hast Du nach der Aenderung an der php.ini Deinen Webserver neu gestartet?

    Gruss,
    jkondek



  • Hallo jkondek,

    vielen Dank für die schnelle Antwort.
    Nachdem dies in besagtem Fenster moniert wurde, habe ich die php.ini dahingehend angepasst, den Eintrag "post_max_size" gesucht und abgeändert auf den Wert wie in der Meldung gefordert 128M. Abschließend habe ich den Apache Dienst (mehrfach) neu gestartet.

    Gruß
    Andreas


  • i-doit Kenner

    Hallo Andreas,

    hast Du versucht, den Wert groesser 128M zu setzen? Beispielsweise 129M?
    Ich meine, ich haette mit solch einem Phaenomen auch mal zu tun gehabt, dass es nicht "groesser gleich" sein durfte, sondern "groesser" sein musste.

    Gruss,
    jkondek



  • Hallo Andreas,

    blöde Frage, ich weiß, aber hast Du auch die richtige php.ini genommen? Und wenn ja, hast Du evtl. noch in anderen Konfigurationen (z.B. beim apache2) weitere PHP-Werte gesetzt?

    Gruß Martin



  • Hallo jkondek,

    ja, ich habe mit verschiedenen Werten herumexperimentiert (16M, 32M u. 129M), habe sogar ein Semikolon davorgesetzt um zu schauen was passiert. Es schien so, als würde es den Apache oder PHP überhaupt nicht zu interessieren. Er zeigt immer Stur 64M an siehe Screenshot. Ich weis nicht woher er den Wert nimmt. Sämtlichen Cache des Browsers und des idoit gelöscht und den Apache runter und rauf gestartet.

    @HofMar
    ich habe auf dem ganzen System nur eine php.ini gefunden, die anderen die ähnlich aufgebaut sind heißen php.ini-production oder develoment. Einen weiteren Wert den ich auf Anraten des Systems in dieser ini verändert habe war: max_input_vars:10000 hier war ein Semikolon davor

    Habe dann das ganze XAMPP Paket aktualisiert und geschaut was nach Installation in der php.ini an dieser Stelle steht –> 8M. Ohne Veränderung das idoit gestartet und in der Verwaltung stand dann immer noch 64M.

    Gruß
    Andreas

    php_ini_idoit.jpg



  • hi,

    bitte daran denken, dass unter Debian z.B. unterschiedliche php.ini Dateien verwendet werden. Für den Apachen ist dies die:

    /etc/php5/apache2/php.ini

    Bei anderen Distributionen kann das ähnlich sein. Am Besten in diesem Fall eine test.php anlegen mit phpinfo:

    
    // Zeigt alle Informationen (Standardwert ist INFO_ALL)
    phpinfo();
    ?>
    
    

    um dann dort zu sehen, welche Datei verwendet wird.

    cu denny



  • Hallo Andreas,

    auch unter https://www.apachefriends.org/faq_windows.html findet man den Hinweis auf mehrer php.ini:

    Why have changes in my php.ini not taken effect?
    If a change in the "php.ini" has no effect, it's possible PHP is using a different one. You can verify this with phpinfo(). Go to the URI http://localhost/xampp/phpinfo.php and search for "Loaded Configuration File". This value shows you the "php.ini" PHP is really using.

    Note: After changing the "php.ini" you have to restart Apache so that Apache/PHP can read the new settings.

    Daher wäre der Tip von Denny hilfreich. Wenn Du wirklich nur eine php.ini gefunden hast, wäre es auch möglich, daß diese trotzdem nicht verwendet wird, da die php.ini an einer ganz anderen Stelle erwartet wird. Dann kannst Du an der vorhandenen php.ini Werte verändern wie Du möchtest, es würden immer die Standardwerte verwendet.

    Des weiteren kann man auch in der Konfiguration des apache2 eine Parametrisierung des PHP mittels php_value und php_flag vollziehen. Näheres unter http://php.net/manual/de/configuration.changes.php. Das kann teilweise auch in einer .htaccess enthalten sein!

    Und zu guter letzt findet sich beim letzten Link noch der Hinweis, daß wenn PHP unter Windows läuft, diese Parametriesierung auch über die Registry erfolgen kann.

    Gruß Martin



  • Hallo HofMar,

    vielen Dank für die Hinweise.
    Nach dem Aktualisieren auf die neue XAMPP Version stand in der phpinfo des PHP-Admin schon der richtige Pfad für die geladene Datei drin C:\XAMPP\php\php.ini.
    Allerdings könnte ich mir vorstellen, dass bei meiner Installation etwas nicht gepasst haben könnte. Ich habe dann unter htdocs ein 2. Verzeichnis (idoit2015) angelegt und hier ein frisches Setup aufgerufen. Gleich zu beginn beim pre-flight-check wurden dann die richtigen Werte ausgelesen (grüne Häkchen).

    Gruß
    Andreas

    php_loaded_file.jpg


 


Datenschutz / Privacy Policy