Problem mit Dateiverwaltung zumindest ab 1.7.3 (kein Upload möglich)



  • Hallo!
    Die Datei-/Versionskontrolle ist in i-doit nicht besonders einfach oder elegant gelöst.
    Neue Dateien kann ich nur über bestehende andere Objekte in die Datei-/Versionsverwaltung. Das Menü unter ->Andere -> Dateien bietet zwar einen Menüpunkt "Neu" an, aber Dateien hochladen kann man hier wider der Erwartung NICHT hochladen. Es wäre - warum auch immer - nur möglich ein Objekt anzulegen mit Angaben zu "Allgemein", "Kontakt" "Workflow" (auch ein schwieriges Modul) und eben "Dateien". Nur kann man hier keineswegs Dateien hochladen. Hier sollte mE eine Änderung ohnehin erfolgen.

    Ein Upload gelingt mir allein unter dem Menüpunkt "Dateizuweisung" bei entsprechenden bestehenden anderen Objekten. Hier kann dann unter "Neu" (bislang) eine Datei-Zuordnung erzeugt werden, indem mittels "Lupe" ein Datei-Browser mit entsprechenden Funktionen aufgerufen wurden. Wie gesagt bislang!

    Nach Rückkehr aus dem Urlaub habe ich von der in dieser Sache fehlerfrei laufenden Version 1.7.1 über 1.7.2 auf die aktuelle Fassung 1.7.3 Updates gefahren.
    Bei dem zuvor geschilderte Aufruf des Datei-Browsers stürzt der entsprechende Browser (bzw Tab) einfach ab. Es wird - bis auf Schließen des Fensters oder Tabs - kein Befehl mehr entgegen genommen. Also Fenster abschießen ggf. anderenorts weiter arbeiten. Dieser Fehler ist beliebig reproduzierbar.

    Ausweislich des beiliegenden Screenshots liegt ein "Fehler! Achtung! Aufgrund von Sonderzeichen o.Ä. konnten die Datei-Objekte nicht korrekt geladen werden!" vor.
    Es dazu anzumerken, dass SÄMTLICHE Objekte über eben diesen Datei-Browser ohne Fehlerhinweis eingefügt wurden. Mir ist nicht klar, wo das störende "Sonderzeichen" sich befindet, welches es sein sollte und wie man dies dann beseitigen könnte. Es ist aber mE ohnehin seltsam noch in diesen Zeiten über Sonderzeichen derart zu stolpern.

    Ich würde es sehr begrüßen, wenn die Upload-Funktion repariert wird und auch generell eine Überarbeitung stattfinden würde.

    Was kann ich bis dahin als work-around selbst tun?
    Nur warten und die jetzt fehlenden Dokumentationen und andere Dateien mit Objektbezug auf einen Zettel schreiben ist wohl nicht der richtige Weg.
    idoit_Dateifehler.png



  • Der Support konnte mit folgender Info helfen:
    "Was die Umlaute angeht haben wir vor einiger Zeit die Kodierung auf UTF-8
    umgestellt, sodass in neueren Versionen etwas derartiges nicht mehr passieren
    sollte. Nichtsdestotrotz haben Sie nun irgendwo eine oder mehrere Dateien, die
    dafür sorgen, dass das Fenster nicht mehr funktioniert. Meine Herangehensweise
    wäre in dem Fall, dass Sie alle Dateien temporär archivieren (eventuell vorher
    eine Sicherung der Datenbank anlegen, zu der Sie später wieder zurückkehren
    können) und den Objektbrowser der Dateizuweisung in einem weiteren Tab oder
    Fenster öffnen. Nun können Sie in dem einen Fenster die Dateien nacheinander
    wiederherstellen und im anderen Fenster die Seite neu laden, den Browser
    aufrufen und schauen, ob die Meldung erscheint, bis Sie die Datei haben, die
    das Verhalten auslöst. Diese würde ich dann dort umbenennen oder herunterladen
    und erneut hochladen."

    Wobei es mE nicht am Dateinamen der PDF lag, sondern VERMUTLICH an - natürlich nicht sichtbaren - mehreren Leerzeichen hinter der "Versions-Beschreibung" der ersten Version. Als diese gelöscht wurden, lief der Dateibrowser wie gewohnt. Vorher lies sich der Fehler bei dieser Datei reproduzieren. Am Rande sei darauf hingewiesen, dass es sich nicht um die letzte hochgeladene Datei handelte, was man ja nach diesen Informationen eigentlich erwarten könnte.

    Vielen Dank an den Support an dieser Stelle.


  • i-doit Kenner

    Gerne doch. 🙂


 


Datenschutz / Privacy Policy