[Gelöst] Suche funktioniert nicht nach update auf 1.8 OPEN



  • Hallo zusammen,

    seit dem update auf die Version 1.8 (von 1.4.8 ) funktioniert die Suche nicht mehr. (s.i. Bild)
    Das Update auf die Version 1.8.3 hat auch keine Abhilfe geschaffen.
    Kann mir jemand bei dem Phänomen weiterhelfen?

    System:
    I-DOIT Open 1.8.3
    Ubuntu 14.04.4
    Apache 2.4
    Mysql 5.6

    Vielen Dank schon mal für die Hilfe
    Viele Grüße
    Micha
    idoit_suche.JPG


  • i-doit Kenner

    Hallo Micha,

    schau mal hier, vielleicht hilft das weiter:

    https://forum.i-doit.org/index.php/topic,4724

    vielleicht kannst Du mal versuchen, die Suche zu reindexen?

    ./controller -u admin -p admin -i 1 -m search_index reindex

    Gruss,
    jkondek



  • nein, es hat leider nicht funktioniert.
    die "Suchseite" wird weiterhin nicht gefunden.

    Die Suche ist eine recht heufig verwendete Funktion, auf die man nicht verzichten kann.

    Hat ggf. noch wer eine idee dazu?

    danke
    &
    Gruß
    Micha


  • i-doIT Team

    Hallo Micha,

    der Fehler liegt an der Apache-Konfiguration. Zwei Dinge sind wichtig:

    • VHost-Konfiguration: AllowOverride All

    • Apache-Modul rewrite aktivieren

    Bitte beachte dazu die Artikel in der Knowledge Base, zum Beispiel: https://kb.i-doit.com/display/de/Systemeinstellungen

    Viele Grüße
    Benjamin



  • Hallo,

    und wenn auch das nicht funktioniert? Apache Config sieht wie folgt aus:

    Alias /idoit "/var/www/idoit/"

    DocumentRoot /var/www/idoit/

    <directory var="" www="" idoit="">AllowOverride All
      Require all granted</directory>

    Es laufen auf dem Server mehrere Webseiten und und es wird permanent nach https redirected.

    Danke!



  • Hallo zusammen,

    ich habe auch das Problem.

    Die vHost ist auch richtig konfiguriert. Im Idoit selber bekomme ich folgende Fehlermeldung:

    Apache Modules
    mod_rewrite Events, Search, Verkabelungen Please verify that the apache module "mod_rewrite" is correctly configured. An automatic check identified that it is not.

    Ich weiss aktuell nicht wo ich noch schauen soll.

    Lieben Dank für die Hilfe


  • i-doIT Team

    @ Cornitus: Gibt es eine konkrete Fehlermeldung? Für HTTPS existiert eine ähnliche VHost-Konfig?

    @Ruhrpott00: mod_rewrite ist aktiviert und PHP läuft unter mod_php? Es kann sein, dass diese Abfrage unter Verwaltung > Systemtools > Systemübersicht einen Fehler meldet, die Suche aber trotzdem funktioniert. Kommt HTTPS zum Einsatz?



  • Hallo,

    danke für die Antwort.

    Wenn ich in der vhost config den DocumentRoot entsprechend auf /var/www/idoit stelle dann funktioniert alles, auch die Suche. Wenn ich dies wieder zurück auf die "korrekte" Seite stelle (CMS) und die oben genannte config nachlade dann funktioniert zwar idoit aber nicht die Suche.

    Fehlermeldung: Error 404 Seite nicht gefunden.

    So sieht die 000-default.conf aus:

    <virtualhost *:80="">ServerAdmin administrator@blub.de
            ServerName blub.de
            ServerAlias blub.de *.blub.de

    RedirectPermanent / https://www.blub.de/</virtualhost>

    So sieht die default-ssl.conf

    <ifmodule mod_ssl.c=""><virtualhost *:443="">ServerAdmin administrator@blub.de
            ServerName www.blub.de
            ServerAlias blub.de *.blub.de

    DocumentRoot /var/www/cms
            <directory>Options FollowSymLinks
                  AllowOverride None</directory>
            <directory var="" www="" cms="">Options Indexes FollowSymLinks MultiViews
                    AllowOverride All
                    Order allow,deny
                    allow from all</directory>
            ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
            <directory "="" usr="" lib="" cgi-bin"="">AllowOverride None
                    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    Order allow,deny
                    Allow from all</directory></virtualhost></ifmodule>

    Dort ist natürlich noch der Teil mit dem Zertifikat vorhanden…den habe ich jetzt erstmal weg gelassen.

    Danke!


  • i-doIT Team

    Hallo,

    ich würde einmal folgende Config für den SSL-VHost ausprobieren:

    
    DocumentRoot /var/www/
            <directory var="" www="" idoit="">AllowOverride All
                  Require all granted</directory> 
            <directory var="" www="" cms="">Options Indexes FollowSymLinks MultiViews
                    AllowOverride All
                    Require all granted</directory> 
    
    

    Das ändert allerdings die Links für das CMS auf https://blub.de/cms/ und für i-doit auf https://blub.de/idoit/.

    Viele Grüße
    Benjamin



  • @bheisig:

    Hallo Micha,

    der Fehler liegt an der Apache-Konfiguration. Zwei Dinge sind wichtig:

    • VHost-Konfiguration: AllowOverride All

    • Apache-Modul rewrite aktivieren

    Bitte beachte dazu die Artikel in der Knowledge Base, zum Beispiel: https://kb.i-doit.com/display/de/Systemeinstellungen

    Viele Grüße
    Benjamin

    Hi,

    vielen Dank, es funktioniert nun wieder!

    Gruß
    Micha


 


Datenschutz / Privacy Policy