Can't import XML files.



  • I can't import any .xml or .csv files from the i-doit XML import. When i select a file from the File Upload -> Browse the screen flickers once but the file is not visible in the user interface. I can see the uploaded file from command line in the imports folder so it does something but is not fully working. Any idea why the file is not showing in the GUI? I tried to verify that i have installed all necessary modules (MySQL, PHP etc.) which should be fine. I'm running i-doit version 1.9.3 on RHEL7. I also tried to export stuff from the system, but it also does not work. When i have made the selection i want to export and click the Export button it just goes back to the beginning (Step 1). Help please? 🙂



  • Add to this that i don't get any errors on i-doit logs or in apache logs. Is there some specific formatting for the structure of data when importing? I have verified that the encoding is UTF8 in my import files.


  • administrators

    I think it's a bug. The file has an invalid structure, but i-doit does not report that correctly. It should report it, but it does not.
    I just reported the bug to our dev team.
    Try to export a XML file and compare it to your xml file. It has to follow the i-doit XML structure.


 


Datenschutz / Privacy Policy