Globale Suche in 1.10.2 Pro funktioniert nicht



  • Hallo,

    habe unsere Pro Version 1.9.4 auf 1.10 upgedatet und dann auf die 1.10.2.

    Jetzt müssen wir feststellen, dass die Globale Suche, ganz rechts oben in der Ecke mit dem Fragezeichen davor nicht mehr funktioniert.
    Wird in das Feld geklickt, vergrößert es sich und verhält sich wie ein normales Textfeld (keine Textvorschläge!).
    Drücke ich Enter nach der Eingabe, erhalte ich die Fehlermeldung vom Browser:

    The requested URL /i-doit/search was not found on this server. (404)

    URL -> http://[hostname]/i-doit/search?q=mo001 ([hostname] = der unseres Servers)

    Im root Web-Verzeichnis von i-doit, gibt es jedoch keine search.php(?) Datei!
    Und diese gab es auch vorher bei Version 1.9.4 nicht (im Backup geschaut), ebenso gibt es keine Datei mit der Bezeichnung "search.*" im 1.10.2 (Full) Installationspaket.

    Getestet unter IE 11 (Win7) und Firefox 52.7.3 (Win7)

    Die Suche in einer Kategorie, rechts über der Elemente Tabelle funktioniert.

    Server: debian 9.1, php7

    Hat jemand eine Idee?

    Vielen Dank.
    Gruß
    J. Schneider



  • Wahrscheinlich eine Fehlkonfiguration des Apache: Entweder wird die .htaccess nicht ausgewertet oder mod_rewrite ist nicht aktiviert.



  • Lösung:

    warum auch immer, wurden die Einträge in der Apache2 Seiten-Konfiguration entfernt, damit die .htaccess Anweisungen auch ausgeführt werden

        <Directory /var/www/html/>
                Options FollowSymlinks
                AllowOverride All
                Require all granted
        </Directory>
    

    dies wieder ergänzt, apache2 neu gestartet und siehe da, die Suche funktioniert wieder.

    Danke.


Log in to reply
 


Datenschutz / Privacy Policy

Looks like your connection to Community was lost, please wait while we try to reconnect.