Umlaute werden im Browser nicht angezeigt



  • Wenn bei Euch im Browser statt den Umlauten (ä, ö, ü) andere Symbole (z.B. ein Fragezeichen) auftauchen, dann könnt Ihr das wie folgt beheben:

    1.) Apache Konfigurationsdatei öffnen
    Für Apache nach der Version 2 öffnet Ihr die Datei "apache2.conf"
    Für Apache vor der Version 2 öffnet Ihr die Datei "httpd.conf"

    Wo diese liegt hängt davon ab, wo Ihr Apache installiert habt.

    2.) Zeichentabelle für ISO-8859-1 aktivieren
    Sucht in der geöffneten Konfigurationsdatei nach "ISO-8859-1".
    Entfernt am Zeilenanfang den Kommentar (= '#').
    Speichert die Datei ab.
    Startet den Apache neu.

    3.) Überprüfung der Änderungen
    Ladet Eure i-doit Seite neu. Die Umlaute sollten nun korrekt dargestellt werden!

    Anmerkung: diese Beschreibung ist für Benutzer des Betriebssystems Unix gedacht.



  • Falls in Schritt 2 kein ISO-8859 gefunden wird, einfach folgendes in der Konfigdatei eintragen:

    AddDefaultCharset ISO-8859-15

    Das kann natürlich auch innerhalb einer <directory>definition eingestellt werden.

    PS: Unter Windows funktioniert die Vorgehensweise auch.</directory>



  • Unter Redhat basierenden Distributionen legt man einfach folgende Datei an:

    /etc/httpd/conf.d/idoit.conf

    
    ### idoit
    
     <location i-doit="">AddDefaultCharset ISO-8859-1
    #   AddDefaultCharset ISO-8859-15</location> 
    
    

    selbige Datei unter Debian basierender Distributionen (also z.B. auch Ubuntu) muss nach /etc/apache2/mods-enabled/idoit.conf

    Charset je nach Bedarf anpassen (in obrigen Beispiel also ISO-8859-1

    Das Beispiel geht davon aus, dass i-doit unter http://servername/i-doit/ erreichbar ist.


Log in to reply
 


Datenschutz / Privacy Policy