Error on update from 1.12.4 to 1.13



  • Hey there,
    I wanted to update my i-doit from
    1.12.4 (rev 201911204)
    to
    1.13 (rev 201911300)

    Everytime I start with the update, I get an "Internal Server Error".

    This is what I get in my apache error.log:
    "[Wed Sep 25 16:01:14.653239 2019] [core:error] [pid 23541] [client xxx.xxx.xxx.xxx:55776] AH00027: No authentication done but request not allowed without authentication for /index.php. Authentication not configured?"

    And this is my apache site config:

    <VirtualHost *:80>
     ServerName  localhost
     Redirect / https://localhost/
    
     DocumentRoot /var/www/html/idoit/
    
     <Directory /var/www/html/idoit/>
      AllowOverride All
      Require all granted
     </Directory>
    
     LogLevel warn
     ErrorLog ${APACHE_LOG_DIR}/idoit_error.log
     CustomLog ${APACHE_LOG_DIR}/idoit_access.log combined
    </VirtualHost>
    
    <IfModule mod_ssl.c>
    <VirtualHost *:443>
     ServerName localhost
     DocumentRoot /var/www/html/idoit/
    
     <Directory /var/www/html/idoit/>
      AllowOverride All
      Require all granted
     </Directory>
    
     SSLEngine On
     SSLCertificateFile /path/to/certificate/acme.crt
     SSLCertificateKeyFile /path/to/certificate/acme.key
     SSLCertificateChainFile /path/to/certificate/acme.crt
    </VirtualHost>
    </IfModule>
    

    What am I doing wrong or missing?

    Thanks in advance and kind regards,
    -Manuel


  • i-doIT Team

    Hello Manuel,

    i think you tried to configure SSO in the past and didnt finished it.
    In i-doit we proof in our htaccess files if mod_auth_kerb is installed

        ## …except some PHP files in root directory:
        <FilesMatch "^(index\.php|controller\.php|proxy\.php)$">
            <IfModule mod_auth_kerb.c>
                Require valid-user
            </IfModule>
            <IfModule !mod_auth_kerb.c>
                Require all granted
            </IfModule>
        </FilesMatch>
    
    

    Now you can do two things. Configure your SSO until it runs fine or disable/uninstall the module.

    Best regards
    Patrick



  • Hello Patrick,
    thanks a lot for your answer.

    The sso module in i-doit was already disabled, but I additionally disabled the kerb mod for apache. Now I got a php fatal error:

    [Tue Oct 15 11:21:35.258244 2019] [php7:error] [pid 26725] [client 192.168.66.61:54465] PHP Fatal error: Uncaught Error: Call to undefined method Symfony\Component\DependencyInjection\ContainerBuilder::hash() in /var/www/html/idoit/vendor/symfony/dependency-injection/Loader/YamlFileLoader.php:145\nStack trace:\n
    #0 /var/www/html/idoit/src/classes/core/isys_application.class.php(194): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->load('/var/www/html/i...')\n#1 /var/www/html/idoit/src/bootstrap.inc.php(71): isys_application->bootstrap()\n#2 /var/www/html/idoit/index.php(101): include_once('/var/www/html/i...')\n
    #3 {main}\n thrown in /var/www/html/idoit/vendor/symfony/dependency-injection/Loader/YamlFileLoader.php on line 145, referer: https://idoit.xxx.xxx.xxx/?load=update

    😕

    Greetings,
    -Manuel


Log in to reply
 


Datenschutz / Privacy Policy