Please update your databases to i-doit 1.2.1 using the updater



  • Hallo,

    ich bin gerade dabei die 30 Tage Pro Version zu testen.

    Gestren hatte ich im Downbloadbereich die Version idoit-1.2.1.zip heruntergeladen und installiert.

    Nach dem aufruf der URL kommt dann dieses hier.

    The version of your i-doit database does not match the version of your program code. Please update your databases to i-doit 1.2.1 using the updater or revert/update your i-doit source code to version 1.2.

    System Database Version: 1.2
    Source Code Version: 1.2.1

    Ich versuche dan auch die weiteren Schritte die mir zu dem Update angeboten werden, aber er findet keine Updates.

    Ich kann mich dann auch nachdem ich die URL ein zweites mal aufgerufen habe normal einloggen.
    Es scheint auch alles ohne Probleme zu funktionieren.

    Doch nach einem erneuten Anmelden kommt das ganze wieder.

    Jemand eine Idee??

    Gruß

    Heiko



  • Hallo Heiko,

    dieses Problem scheint bei einigen Installationen aufzutreten - Im Grunde ist das aber nichts wildes, da es sich bei dir um eine frische Installation handelt.
    Diese Meldung ist dafür Gedacht wenn ein System mit mehreren Mandanten nicht vollständig auf einer Version läuft (Mandant A: 1.2, Mandant B: 1.2.1, …) 🙂 Es ist möglich die Version in der Datei "<i-doit>/src/globals.inc.php " anzupassen - dadurch sollte die Meldung umgangen werden.

    Sobald sich der Update-Prozess öffnet, lässt sich dieser einfach umgehen, indem man in der URL alles nach "index.php" entfernt.

    Wir werden prüfen ob das ggf. schon im aktuellen Download-Paket repariert ist.

    Viele Grüße
    Leo</i-doit>



  • Das gleiche Problem hatte ich auch. Habe den Vorschlag von "LFischer" gemacht. Leider habe ich noch folgende Probleme:

    1. Ich erhalte bei allen Widgets folgende Meldung: Error. Widget ''does not exist.
    2. Umlaute werden durch Symbole angezeigt.

    Kann mir da jemand einen Tipp geben, wie man das ganze Problem beheben kann?



  • @egnaz:

    Das gleiche Problem hatte ich auch. Habe den Vorschlag von "LFischer" gemacht. Leider habe ich noch folgende Probleme:

    1. Ich erhalte bei allen Widgets folgende Meldung: Error. Widget ''does not exist.
    2. Umlaute werden durch Symbole angezeigt.

    Kann mir da jemand einen Tipp geben, wie man das ganze Problem beheben kann?

    Hallo egnaz,
    es klingt ganz so als hättest du ein falsches Update eingespielt… Deine genannten Fehler lassen sich reproduzieren wenn man ein Major Release überspringt oder nur die PHP Dateien updated (aber nicht die Datenbank). Könntest du genau aufschreiben, wie du vorgegangen bist (Welche Updates / Wurde etwas übersprungen / ...).

    Mit freundlichen Grüßen
    Leo


 


Datenschutz / Privacy Policy