Fehler beim RFC-Modul - Requested URL was not found



  • Hallo i-doit Gemeinde,

    wir haben zu Testzwecken eine VM auf CentOS 7 x64 mit i-doit 1.4.9 pro installiert. Zusätzlich sind die Module "Analyse", "Dokumente" und "RFC" installiert.

    Leider funktioniert der Aufruf des RFC-Moduls nicht so recht.

    Fehlermeldung: The requested URL /rfc/frontend was not found on this server. (Mozilla Firefox)

    In einem anderen Beitrag ( http://forum.i-doit.org/index.php/topic,3397.msg11038.html#msg11038 ) habe ich bereits etwas ähnliches entdeckt, jedoch sind meine php-Kenntnisse recht überschaubar. 😉
    Den Eintrag der base_url habe ich angepasst, leider ohne Erfolg.

    Info's zum Server:
    CentOS 7 x64 - Minimal Installation (VMware)
    Apache Webserver mit PHP 5.4.16 und MariaDB 5.5.40
    Benötigte php extensions (Dokumentation RFC) sind installiert.
    RFC - Modul über Admin - Center installiert und "Ok".
    In der Systemübersicht von i-doit alles "grün". (System, php.ini, MySQL, php-modules, rights & directories) - php.ini und mysql settings angepasst.

    Inhalt der .htaccess:
    cat .htaccess
    Options Indexes FollowSymLinks

    Turn on URL rewriting

    RewriteEngine On

    Installation directory

    RewriteBase /rfc/

    Protect hidden files from being viewed

    <files .*="">Order Deny,Allow
    Deny From All</files>

    Protect application and system files from being viewed

    RewriteRule ^(?:application|modules|system)\b.* index.php/$0 [L]

    Allow any files or directories that exist to be displayed directly

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d

    Rewrite all other URLs to index.php/URL

    RewriteRule .* index.php/$0 [PT]

    Ich hoffe ich habe nichts vergessen und Ihr habt eine Lösung parat. 🙂

    Vielen Dank im Voraus und viele Grüße
    Mr.White


  • i-doit Kenner

    Hi,

    klingt nach fehlendem/nicht konfiguriertem mod_rewrite. Du musst mod_rewrite aktivieren und für den VHost "AllowOverride All" setzen. Damit sollte es dann gehen.

    Lieben Gruß



  • Hallo creiss,

    vielen Dank für den Hinweis!
    Ich wusste zwar nicht was mod_rewrite ist, aber nach etwas googlen wurde ich fündig. 🙂
    Falls noch jemand anderes das Problem hat:

    #grep -r -H durchsucht rekursiv alle verzeichnisse unter /var nach "mod_rewrite" und gibt mit Option -H den Pfad aus
    [root@Server0815/]# grep -r -H "mod_rewrite" /var
    … /var/www/html/i-doit/rfc/system/guide/kohana/tutorials/clean-urls.md:If you are still getting errors, check to make sure that your host supports URL mod_rewrite. If you can change the Apache configuration, add these lines to the the configuration, usually **httpd.conf**:

    #find -iname httpd.conf durchsucht alle verzeichnisse nach der Datei httpd.conf
    [root@Server0815/]# find -iname httpd.conf
    ./etc/httpd/conf/httpd.conf

    [root@Server0815/]# grep -r -H "AllowOverride" /etc
    /etc/httpd/conf/httpd.conf:    AllowOverride None

    siehe auch hier (in Zeile 151): http://www.server-world.info/en/note?os=CentOS_7&p=httpd

    Viele Grüße
    Mr.White


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.