[1.6.3] Direkte Verlinkung von URLs in Report-Ergebnissen - funktioniert nicht


  • i-doit Kenner

    Hallo,

    in der aktuellen Version 1.6.3 ist folgender Eintrag im Changelog:

    [Verbesserung] Direkte Verlinkung von URLs in Report-Ergebnissen

    Wenn ich einen Report erstelle, welcher mir neben dem Objektlink die Website aus der spezifischen Kategorie Organisation ausgeben soll, kommt es zu folgendem Fehler:

    Database error : Query error: 'SELECT obj_main.isys_obj__id AS 'id', obj_main.isys_obj__title AS 'LC__UNIVERSAL__TITLE###1', j. AS 'isys_cmdb_dao_category_s_organization_master::dynamic_property_callback_website::::LC__CONTACT__ORGANISATION_WEBSITE' FROM isys_obj AS obj_main INNER JOIN isys_cmdb_status AS obj_main_status ON obj_main_status.isys_cmdb_status__id = obj_main.isys_obj__isys_cmdb_status__id LEFT JOIN isys_obj_type AS j5 ON j5.isys_obj_type__id = obj_main.isys_obj__isys_obj_type__id WHERE TRUE AND ( (j5.isys_obj_type__id = '107' ) ) ;': You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AS 'isys_cmdb_dao_category_s_organization_master::dynamic_property_callback_webs' at line 4

    Schaut man sich die Abfrage genauer an, stellt man fest, dass das SELECT-Statement unvollstaendig ist (vermutlich fehlt auch ein JOIN in die betroffene Tabelle):

    SELECT
    obj_main.isys_obj__id AS 'id',
    obj_main.isys_obj__title AS 'LC__UNIVERSAL__TITLE###1',
    j. AS 'isys_cmdb_dao_category_s_organization_master::dynamic_property_callback_website::::LC__CONTACT__ORGANISATION_WEBSITE'

    FROM isys_obj AS obj_main
    INNER JOIN isys_cmdb_status AS obj_main_status ON obj_main_status.isys_cmdb_status__id = obj_main.isys_obj__isys_cmdb_status__id
    LEFT JOIN isys_obj_type AS j5 ON j5.isys_obj_type__id = obj_main.isys_obj__isys_obj_type__id

    WHERE TRUE

    AND  ( (j5.isys_obj_type__id = '107' ) ) ;

    Dabei ist auch aufgefallen, dass die beiden JOINS, die bereits vorhanden sind, ueberhaupt nicht gebraucht werden!
    Die Tabelle isys_cmdb_status wird nicht genutzt und die obj_type__id koennte man genauso gut aus der isys_obj Tabelle beziehen.

    Vielleicht sollte man den Abfrage-Editor entsprechend anpassen.

    Danke und Gruss,
    jkondek



  • Hallo jkondek,

    ich vermute Cache leeren und Properties erneuern hat nicht geholfen? Könntest du uns die genauen Felder auflisten die in der Abfrage und der Bedingung enthalten sind (ggf. Screenshot)?

    Viele Grüße
    Leo


  • i-doit Kenner

    Hallo Leo,

    falls Du heute in die Demo schaust, waere da der Report "Amazon Website" als Beispiel.

    Falls nicht, hier der Weg zur Reproduzierung:
    1. Report via Report Manager erstellen
    2. Titel: Amazon Website
    3. Ausgabe: spezifisch > Organisation > Attribut Webseite auswaehlen (Name (Allgemein) ist standardmaessig ausgewaehlt, dieses bestehen lassen)
    4. Bedingungen: Kategorie Allgemein > Attribut Name = Amazon
    5. Ausgabe pruefen oder speichern.

    Beim Pruefen kommt eine Fehlermeldung (vgl. Screenshot).

    Das Problem laeuft bereits unter der Ticketnummer #2764.

    Gruss,
    jkondek

    Unbenannt.png



  • Hallo jkondek,

    alles klar, konnte das Problem relativ schnell reproduzieren!
    Wir werden dieses zur nächsten Minor und Major Version gelöst haben 🙂

    Viele Grüße aus Düsseldorf
    Leo


  • i-doit Kenner

    Ich wuerde gerne noch mal auf das Problem in diesem Post aufmerksam machenn.
    Inzwischen gibt es schon die Version 1.8.1 und das Problem ist immer noch vorhanden.

    Gruss,
    jkondek



  • Hab's Leo nochmal freundlich auf "Wiedervorlage" gelegt 😃



  • Hallo jkondek,

    ich habe mir mal die Änderung angeschaut die im Ticket #2764 gemacht wurde. Bei der Änderung wurde das Dynamische Attribut für "Website" mit dem Statischen Attribut getauscht. D. h. das der Wert der angezeigt wird nicht mehr dynamisch über ein Callback aufbereitet wird sondern direkt vom Datenbankfeld entnommen.
    Versuch mal das Attribut vom Report zu entfernen und dann wieder neu hinzufügen.

    Gruß,
    VQH

    Abfrage-Editor-Organisation-Website.gif


  • i-doit Kenner

    Hallo VQH,

    dass die Website im Report dargestellt wird war schon laenger der Fall, die Aenderung in der 1.6.3 beinhaltet die "direkte Verlinkung von URLs", heisst fuer mich, dass ich auf die URL draufklicken kann und dadurch auf die Website weitergeleitet werde. Dies ist nicht der Fall. Oder verstehe ich die Aenderung falsch?

    Danke und Gruss,
    jkondek


Log in to reply
 


Datenschutz / Privacy Policy