Patchfeld-Belegungsplan drucken



  • Hallo,

    es geht um folgendes:
    In Datenschränken liegt üblicherweise zu jedem Patchfeld ein Belegungsplan, der beim Aufbau durch die Elektriker erstellt wird.
    Ggf. werden diese schon mal handschriftlich ergänzt/korrigiert, wenn z.B. eine Netzwerkdose versetzt wird. Im schlimmsten Fall ist sogar keine Doku vorhanden, was eine Begehung erfordert.

    Nun stellt sich die Frage, ob es möglich ist, eine solche Dokumentation (nach Begehung/Erfassung) aus i-doit zu generieren, wenn ein Patchfeld dort mit allen Infos angelegt ist. Dies wäre hilfreich, um auch ggf. Elektrikern was an die Hand zu geben, wenn Arbeiten anstehen.

    Schön wäre ein Dokument in etwa so, wie in der Anlage abgebildet.
    Hat jemand eine Idee?

    Vielen Dank
    Patchbelegung.JPG


  • i-doIT Team

    Hallo Thomas,

    wenn die Übersicht dem angehängten Bild ähneln soll, hilft sicherlich ein Report weiter. Geht es um i-doit open oder pro? Reports sind nur mit der pro-Variante möglich, siehe https://www.i-doit.org/features/.

    Viele Grüße aus Düsseldorf
    Benjamin



  • Hallo,

    an den Reports habe ich mich schon versucht.
    Es geht um die Pro-Version.

    Viele Grüße


  • administrators

    Hi,

    hast Du denn mit den Reports Ergebnisse erzielen können? Eigentlich solltest Du mit mit dem Report Manager genug Werkzeug in der Hand haben, um die Informationen formatiert herauszubekommen. Schlimmstenfalls auf SQL Ebene.

    Wenn die Reports inhaltlich okay aussehen, kannst Du diese mit dem Dokumente Modul "schön" machen zum Druck.



  • Hallo,

    mir gelingt es eine Report zu erzeuchen, der vom Patchfeld die Felder
    Patchfeldname –> Name (Allgemein)
    Anschlussname --> Bezeichnung (Anschlüsse)
    Anschlusstyp --> Anschlussart (Verkabelung > Anschlüsse)

    beinhaltet.

    Diese sind auch so gefiltert, das mir nur die Ports der Rückseite, wo ich die fest verlegten Kabel angeschlossen habe, angezeigt werden.

    Nun fehlt mir noch die Info je Port, in welchem Raum sich die verbunden Netzwerkdose befindet. Da habe ich noch nicht so die Erleuchtung gehabt, wie ich die hinzufügen kann.

    Zur Veranschaulichung habe ich mal die Konfiguration des Reports als Screenshot beigefügt.

    Das Dokumenten-Modul ist kostenpflichtig, oder?

    Viele Grüße

    Patchbelegung_Report-Konfig.JPG


  • administrators

    Ja,

    das Dokumente Modul ist kostenpflichtig.
    Die verknüpften Zielports herauszufinden dürfte folgendermaßen gehen: Siehe Attachment GIF

    2016-10-25_12-33-18.gif



  • Hallo,

    vielen Dank.
    Nun zeigt er zwar an, das eine Patchdose verbunden ist, allerdings müsste nun von dieser Patchdose noch der Standort (Pfad) ausgegeben werden.

    Viele Grüße


  • administrators

    Hi,

    hier nochmal als GIF:

    2016-10-25_13-41-31.gif



  • Hi,

    erst einmal Danke für die Anleitung! Ich bin bis jetzt mit dem Report Manager noch nicht so ganz klar gekomen, aber jetzt komm ich langsam dahinter wie dieser funktioniert.

    Ich habe versucht den Report in unserem i-doit 1.7.1 nachzumachen. Leider bekomme ich beim Prüfen folgenden Fehler sobald ich das Attribut "Verbunden mit Anschluss (Verkabelung > Anschlüsse)" einfüge, egal welche Unterattribute ich auswähle.

    Ein Fehler ist aufgetreten: Database error : Query error: 'SELECT obj_main.isys_obj__id AS 'id', obj_main.isys_obj__title AS 'LC__UNIVERSAL__TITLE###1', j4.isys_catg_connector_list__title AS 'LC__CMDB__CATG__TITLE###50', j3.isys_connection_type__title AS 'LC__CATG__CONNECTOR__CONNECTION_TYPE###50', j13.isys_obj__title AS 'LC__UNIVERSAL__TITLE#LC__CMDB__OBJTYPE__CABLE###1', j9.isys_obj__id AS 'isys_cmdb_dao_category_g_cable::dynamic_property_callback_connection::isys_obj__id::LC__CATS__CABLE__CONNECTION#LC__CMDB__OBJTYPE__CABLE###151', j16.isys_obj__title AS 'LC__UNIVERSAL__TITLE#LC__CATG__CONNECTOR__ASSIGNED_CONNECTOR###1' FROM isys_obj AS obj_main INNER JOIN isys_cmdb_status AS obj_main_status ON obj_main_status.isys_cmdb_status__id = obj_main.isys_obj__isys_cmdb_status__id LEFT JOIN isys_catg_connector_list AS j6 ON j6.isys_catg_connector_list__isys_obj__id = obj_main.isys_obj__id AND j6.isys_catg_connector_list__assigned_category = 'C__CATG__CONNECTOR' LEFT JOIN isys_catg_connector_list AS j1 ON j1.isys_catg_connector_list__isys_obj__id = obj_main.isys_obj__id LEFT JOIN isys_connection_type AS j3 ON j3.isys_connection_type__id = j1.isys_catg_connector_list__isys_connection_type__id LEFT JOIN isys_catg_connector_list AS j4 ON j4.isys_catg_connector_list__isys_cable_connection__id = j6.isys_catg_connector_list__isys_cable_connection__id AND j4.isys_catg_connector_list__id != j6.isys_catg_connector_list__id LEFT JOIN isys_cable_connection AS j7 ON j7.isys_cable_connection__id = j4.isys_catg_connector_list__isys_cable_connection__id LEFT JOIN isys_obj AS j9 ON j9.isys_obj__id = j7.isys_cable_connection__isys_obj__id LEFT JOIN isys_obj AS j13 ON j13.isys_obj__id = j9.isys_obj__id LEFT JOIN isys_catg_cable_list AS j14 ON j14.isys_catg_cable_list__isys_obj__id = j9.isys_obj__id LEFT JOIN isys_obj AS j15 ON j15.isys_obj__id = j9.isys_obj__id LEFT JOIN isys_obj AS j16 ON j16.isys_obj__id = j1.isys_obj__id LEFT JOIN isys_obj_type AS j18 ON j18.isys_obj_type__id = obj_main.isys_obj__isys_obj_type__id WHERE TRUE AND ( (j1.isys_catg_connector_list__title LIKE '%OUT%' ) ) AND ( (j18.isys_obj_type__id = '43' ) ) LIMIT 0, 25;': Unknown column 'j1.isys_obj__id' in 'on clause' .

    Mit dem Fehler kann ich nicht viel anfangen, da ich kein ITler bin. Funktioniert der Report unter der Version 1.7.1 nicht?

    Gruß Moritz


  • administrators

    hi,

    Updaten kann auf jeden Fall nicht schaden.

    Wenns mit der neusten 1.7.5 oder 1.8 nicht geht, einfach nochmal melden.



  • Hallo zusammen

    Ich hatte das Selbe Problem. Aber auch ein Upgrade von 1.7.3 auf 1.7.4 resp bis 1.8 hat nichts geholfen.

    Roberto



  • hi,

    kannst du ein Screenshot zu den Attributen und der Bedingung vom Report machen? Dann kann ich mir das genauer anschauen woran es genau liegt.



  • Hallo vqh

    nach einem kompletten leeren des Cache hat es heute funktioniert.
    Die Settings sind genau gleich wie in den oberen Beispielen. Leider kann ich nicht genau sagen warum es nach einem Cache clean funktioniert hat.

    Dennoch danke für die Hilfe.


 


Datenschutz / Privacy Policy