Fehler bei Update von 1.48 auf 1.8



  • Hallo zusammen,
    ich bekommen beim Update der Version 1.48 auf 1.8 den Fehler
    Fatal error: Class 'isys_application' not found in C:\WINAPP\xampp\IVMDB\updates\classes\isys_update.class.php on line 643
    Folgende Schritte wurden unternommen:
    Sicherung der DB und Daten Dir
    Kopie des 1.8\updates Dir auf den Server und damit auch Überschreibend er Daten.
    Aufruf von http://Server/updates.
    Ausführen der einzelnen Schritte bis "Yes Updates jetzt durchführen"
    danach erscheint die Meldung.

    OS:
    Windows
    Xamp

    Seltsam war auch da ich nicht angezeigt bekommen habe das er auf 1.8 Updaten möchte.
    Muss hier etwas anders gemacht werden?

    Merci und VG
    R


  • i-doit Kenner

    Hallo TheBob,

    hast Du direkt von 1.4.8 auf 1.8 versucht, das Update durchzufuehren?
    Es koennen nur minor Versionen uebersprungen werden (von 1.4.1 direkt zu 1.4.5 z.B.), aber keine major Versionen (von 1.4.8 auf 1.8 ).
    Es muss zumindest auf alle major Versionen (1.5, 1.6, 1.7, 1.8 ) upgedatet werden, sonst kommt es zu Fehlern und/oder Problemen.

    Welche Version wurde Dir beim Update denn angeboten?

    Gruss,
    jkondek



  • Yep,

    bitte hier https://www.i-doit.org/open-update/ registrieren und dann das Update downloaden. Dieses Update beinhaltet alle Zwischenschritte über 1.5, 1.6 und 1.7 und muss daher mehrfach durchgeführt werden.



  • Salue dkirsten & jkondek,

    mir wurde bis dato NUR das Update vom 1.4.8 to 1.8 Open angeboten.
    Nach dem ich jetzt aber noch mal euren Updatelink aufgerufen habe, bekomme ich ein 1.8er Update angeboten wo alle vor Versionen drin sind.

    Ich habe mich jetzt entschlossen das ganze Neu aufzusetzen bis version 1.48 und dann die Datenbank zurück zu sichern und dann den Rest der Versionen zu installieren.
    Diesen schritt mache ich weil ich das ganze jetzt auf Ubuntu laufen lassen möchte und nicht mehr Windows.
    Die erst Installation von 1.44 und 1.48 ist durch aber ich bekomme keine gut Darstellung hin.
    Bei mir sieht das derzeit so aus:

    Noch fehlt mir der Ansatz woran es liegt. Rechte wurde mittels script gesetzt und Temp gelöscht.

    Darstellung.JPG



  • Hi,

    wenn Du jetzt mit den Darstellungsprobleme auf 1.4.8 bist und Deine Daten da sind, würde ich einfach erstmal die Darstellungsprobleme ignorieren und den Updater weiter bis zu 1.8 hochlaufen lassen (In der Hoffnung, dass die Probleme dann weg sind…). Die URL des Updaters ist http://pfad.zu.idoit/updates.
    Wenn Du dann mit 1.8 oder beim Update noch Probleme hast, kannst Du Dich ja nochmal melden.

    Übrigens, wenn Du keine Lust hast, Dich mit dem OS darunter auseinanderzusetzen ist der einfachste Weg, dass Du Dich auf der Pro Webseite für eine Eval registrierst und Dir die virtuelle Appliance herunterlädtst.



  • Vielen Dank Daniel für deine Infos,

    aktuelle habe ich jetzt update 1.6 drauf und es erscheint folgende Meldung:

    mysqli_connect(): (HY000/2002): No such file or directory (/var/www/html/ivmdb/src/classes/components/isys_component_database_mysqli.class.php:53)

    Nur verwende ich keine MySqli sondern nur MySql und das steht auch so in der config.inc.php drin.
    Dein Vorschlag mit einem fertigen Image kann ich leider nicht folgen da auf dem Server schon andere Web Anwendungen laufen und ich ja dann auch noch die Daten mihrieren müsste bzw. neu einspielen.
    Merci & Vg Remo


Log in to reply
 


Datenschutz / Privacy Policy