LDAP Sync issue / "malformed JSON" syntax error



  • I had I-doIT Pro configured to sync new users from LDAP every night. Out of the blue this stopped working, without any changes being made to the configuration or anything else (that I know of). Trying to start a sync manually gives a "malformed JSON" error:

    [root@idoit-ict i-doit]# sudo -u apache ./controller -v -m ldap sync
    Logging in..
    Connected to tenant: ICT Operations (1, user: controller)
    General error: Syntax error, malformed JSON

    (I-doIT is running on a CentOS 6 server, with PHP5.6 and MariaDB10)

    I could not find anything out of the ordinary in any config or log files, except in I-doIT itself under Administration>System settings>Tenantsettings>LDAP (see attached screenshot). Before I found this I had already tried updating I-doIT to 1.9.3, which did not help with the sync issue (although it did give us the improved search bar, which was a pleasant surprise).

    Does anyone have an idea what happened, what's wrong, or how to fix it?
    idoit_LDAP_config.png


  • i-doit Kenner

    Hi,

    just remove the content in the field shown and you are ready to go. 😉

    Kind Regards,
    Christian



  • This worked like a charm, thanks! The best solutions are the simple ones 🙂


  • i-doit Kenner

    Yes, indeed. 🙂


 


Datenschutz / Privacy Policy