Installation: connection to mysql fails



  • Hi,
    I´m trying to do a clean install of i-doit on an up to date Centos 5 Linux box. I´m actually using revision 2844. I´m trying to do the setup via the web interface but it always ends with an error 13 in the database field, a failed for the database root password (which is correct) and two no link errors for the databases. While this is a fresh installation of the system i´ve installed phpMyAdmin to check the amp setup, it works without any problems. I´ve checked password and usernames at the cli, no problems here. I´m a bit puzzled what might be wrong with my setup so any help is welcome.

    Regards,
    Mike



  • Could you please make a screenshot of the errors?
    Is the i-doit user (you had to give a name for) actually created in the database? Does he have sufficient rights? Are there previous i-doit users in the database?

    What is really suspicious is that the root user is not recognized. If you like too and it's possible you could send me a PM with access to your i-doit setup. Maybe then I will see more clearly what seems to be the problem.



  • Hi,
    I´ve made three screenshots. First is from system check, second is the error itself, third is a database login from the command line.
    The system can´t be accessed from the internet, but I will follow any directions you may guide me.

    check.jpg
    error.jpg
    terminal.jpg



  • I see that you checked the connection to mysql on the CLI with the username you want the setup to create.
    Hm, when you connect to the database using the root user (mysql -D idoit_sys -h localhost -u root -p), using the mysql database and then looking at the user table (select host,user,password from user;), was the i-doit user created by the setup? If so, what host is connected to this entry? If not (I presume that's the case) the setup could never even start to build the database because the root-connection didn't work.

    So the problem is that i-doit cannot connect to the database because there is a problem connecting with the root user. Can you create new databases using your root user?

    Since your mandator's name seems to be in german, erm, you could also use our german side of the forum 🙂



  • Hm, there is no table user in the idoit_sys database. But I guess you are meaning the mysql database. Here is the output of the command:
    | %                        | idiot | 5203a74776cb92fd |
    | localhost                | idiot | 5203a74776cb92fd |
    | idiot                    | idiot | 5203a74776cb92fd |
    I have absolutly no idea where the idiot comes from, the name of the box is linux3, it is configured in /etc/hosts and the local nameserver.  No idiot host in both…
    I´ve now dropped all tables, deleted all i-doit users from the mysql database and started the auto setup all over again: No tables were created, no users where created.

    Since your mandator's name seems to be in german, erm, you could also use our german side of the forum

    Yes, you are right, even if my real first name is Mike. Just jumped into the forum from the start page and jumped into the first matching category without any closer looks…



  • Hm, now it gets a bit complicated 😉
    With you first i-doit installation the users seemed to be created by i-doit, with an additional 'idiot' host, this is a thing the Setup should not ever do.
    The second installation on the other hand didn't create any user or host, which is very ominous.

    I must admit that I'm puzzled, we didn't ever have such occurrences with our systems. The only conclusion I come up with is that somehow the root password you are using is wrong or has strange characters which i-doit doesn't understand 😉
    Or maybe somebody removed the wrong hosts from the user table (no hidden accusation here) so that i-doit can't connect to mysql via the root user. Or you really have to specify another port for the mysql connection in i-doit.



  • Hi, back from a long weekend. Ok, the password is much too simple to cause any problems, it´s not even a password anybody would use in the wild. So what I´ve tried now is to set up the i-doit system on a Trustix box. Here I get the following message when I try to login to do the i-doit setup:
    Not all needed extensions are installed.
    I need: mysql xml standard pcre session
    I have: xml standard pcre session
    Looks like some php related stuff. If you may give me a hint I will try to setup i-doit. While I´m not very familiar it would be nice if you give me some more detailed instructions, where to find the extension or where to but it.
    Thanks,

    Mike



  • Just a small update: I did a eGroupware installation on the same Centos box which works without any problems. The installation and setup procedure is pretty close to i-doit. The eGroupware didn´t have any problems creating it´s mysql databases, tables and database users at the localhost and port 3306. So the problem is really somewhere inside the i-doit application. Maybe some kind of encryption? The root user password is a combination of the letters a, g and m, so there shouldn´t be any problems with the encoding.

    Regards,

    Mike



  • Hi Mike,
    in an AMP package you may need to activate the mysql extension in your php.ini. How did you install php?

    Activate mysql:
    –-
      - vi /etc/php/php.ini (you may have to correct the path to your php.ini location)
      - add or uncomment the following: extension=mysql.so
    –-

    (If you've compiled it using the sources from php.net, you need to compile php with the mysql extension first. (./configure –with-config-file-path=/etc/php/php.ini --with-openssl --with-mysql ..))



  • Did the entry, restarted apache, same result. The php installation is the distribution based one, which is similar to the RedHat EL 5 installation. I have added my php.ini file. This is the resulting page of info.php:
    './configure' '–build=i686-redhat-linux-gnu' '--host=i686-redhat-linux-gnu' '--target=i386-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-png' '--with-pspell' '--with-expat-dir=/usr' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--enable-yp' '--enable-wddx' '--with-kerberos' '--enable-ucd-snmp-hack' '--with-unixODBC=shared,/usr' '--enable-memory-limit' '--enable-shmop' '--enable-calendar' '--enable-dbx' '--enable-dio' '--with-mime-magic=/etc/httpd/conf/magic' '--without-sqlite' '--with-libxml-dir=/usr' '--with-xml' '--with-apxs2=/usr/sbin/apxs' '--without-mysql' '--without-gd' '--without-odbc' '--disable-dom' '--disable-dba' '--without-unixODBC' '--disable-pdo' '--disable-xmlreader' '--disable-xmlwriter'
    The infos of the module mysql:
    Active Persistent Links 1
    Active Links 1
    Client API version 5.0.22
    MYSQL_MODULE_TYPE external
    MYSQL_SOCKET /var/lib/mysql/mysql.sock
    MYSQL_INCLUDE -I/usr/include/mysql
    MYSQL_LIBS -L/usr/lib/mysql -lmysqlclient
    Directive Local Value Master Value
    mysql.allow_persistent On On
    mysql.connect_timeout 60 60
    mysql.default_host no value no value
    mysql.default_password no value no value
    mysql.default_port no value no value
    mysql.default_socket no value no value
    mysql.default_user no value no value
    mysql.max_links Unlimited Unlimited
    mysql.max_persistent Unlimited Unlimited
    mysql.trace_mode Off Off
    And the infos of the module mysqli
    Client API library version 5.0.22
    Client API header version 5.0.22
    MYSQLI_SOCKET /var/lib/mysql/mysql.sock
    Directive Local Value Master Value
    mysqli.default_host no value no value
    mysqli.default_port 3306 3306
    mysqli.default_pw no value no value
    mysqli.default_socket no value no value
    mysqli.default_user no value no value
    mysqli.max_links Unlimited Unlimited
    mysqli.reconnect

    And finally the output of the package management system:
    php-mysql.i386                          5.1.6-15.el5          installed

    So maybe you can see some problems.

    Greetings,

    Mike



  • Sorry, here comes the .ini file

    php.txt



  • What you wrote earlier, that the extension 'mysql xml standard pcre session' was not installed… is that still the case?



  • Sorry that I´ve puzzled you. I currently trying to install i-doit on two different Linux flavours: CentOS 5, the one which is most of the thread about and Trustix 2.2, the one with the 'mysql xml standard pcre session' was not installed' error. Trustix is actually the system of our production servers. But while support seems to go down for this great system we are looking for another distro. Centos 5 is now the first test environment and I thought it is a good idea to also implement one or two of this "ever wanted but never had the time to get one" services like an it inventory. There is one included with our Zabbix network monitoring system but it´s much too basic to meet our requirements.
    So while I know my ways around with Trustix I´ve tried to install i-doit on such a system but the setup doesn´t start and just the above error pops up. I´ve tried to find the module but hadn´t any success. If you could point me to the right direction I would be very happy.



  • hmm strage , can you check if networking is enabled in mysqld.
    if you type " telnet localhost 3306" the result should be something like
    Trying 127.0.0.1…
    Connected to localhost.localdomain.
    Escape character is '^]'.
    A
    5.0.22-Debian_3-logmzJhM)#s=s,�Oo`sC5{.rtoQ



  • Her is the output:
    [netadmin@linux3 ~]$ telnet localhost 3306
    Trying 127.0.0.1…
    Connected to localhost.localdomain (127.0.0.1).
    Escape character is '^]'.
    4
    5.0.22%YqLiIs&,`5%Vf{X(\xg|
    As you can see we´re both running the same version of mysql...



  • Related to that
    Need: mysql xml standard pcre session    stuff

    I resolved it by installing php-mysql (running on Centos5)
    yum –disablerepo=* --enablerepo=c5-testing install php-mysql

    restart Apache and try again

    boris



  • you may also want to install thoses additional php libraries:

    yum –disablerepo=* --enablerepo=c5-testing install php-curl
    yum --disablerepo=* --enablerepo=c5-testing install php-ldap



  • Hello, i receive the same message if i open http://localhost/i-doit. (message attached)

    I'm using Linux Mint 18.1 Cinnamon 64-bit

    Can someone tell me how I solve this problem?

    Bildschirmfoto vom 2017-03-23 10-57-54.png


  • i-doIT Team

    Hello derHabi,

    Welcome to our i-doit forums!

    Please take a close look at our knowledge base: https://kb.i-doit.com/display/en/Installation

    Linux Mint 18.1 is based on Ubuntu 16.04 which is currently not supported because of PHP 7. Please switch to another GNU/Linux distribution or just wait for i-doit 1.9. The pro version will be published in May.

    Greetings,
    Benjamin


Log in to reply
 


Datenschutz / Privacy Policy