Installation: connection to mysql fails



  • Did the entry, restarted apache, same result. The php installation is the distribution based one, which is similar to the RedHat EL 5 installation. I have added my php.ini file. This is the resulting page of info.php:
    './configure' '–build=i686-redhat-linux-gnu' '--host=i686-redhat-linux-gnu' '--target=i386-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-png' '--with-pspell' '--with-expat-dir=/usr' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--enable-yp' '--enable-wddx' '--with-kerberos' '--enable-ucd-snmp-hack' '--with-unixODBC=shared,/usr' '--enable-memory-limit' '--enable-shmop' '--enable-calendar' '--enable-dbx' '--enable-dio' '--with-mime-magic=/etc/httpd/conf/magic' '--without-sqlite' '--with-libxml-dir=/usr' '--with-xml' '--with-apxs2=/usr/sbin/apxs' '--without-mysql' '--without-gd' '--without-odbc' '--disable-dom' '--disable-dba' '--without-unixODBC' '--disable-pdo' '--disable-xmlreader' '--disable-xmlwriter'
    The infos of the module mysql:
    Active Persistent Links 1
    Active Links 1
    Client API version 5.0.22
    MYSQL_MODULE_TYPE external
    MYSQL_SOCKET /var/lib/mysql/mysql.sock
    MYSQL_INCLUDE -I/usr/include/mysql
    MYSQL_LIBS -L/usr/lib/mysql -lmysqlclient
    Directive Local Value Master Value
    mysql.allow_persistent On On
    mysql.connect_timeout 60 60
    mysql.default_host no value no value
    mysql.default_password no value no value
    mysql.default_port no value no value
    mysql.default_socket no value no value
    mysql.default_user no value no value
    mysql.max_links Unlimited Unlimited
    mysql.max_persistent Unlimited Unlimited
    mysql.trace_mode Off Off
    And the infos of the module mysqli
    Client API library version 5.0.22
    Client API header version 5.0.22
    MYSQLI_SOCKET /var/lib/mysql/mysql.sock
    Directive Local Value Master Value
    mysqli.default_host no value no value
    mysqli.default_port 3306 3306
    mysqli.default_pw no value no value
    mysqli.default_socket no value no value
    mysqli.default_user no value no value
    mysqli.max_links Unlimited Unlimited
    mysqli.reconnect

    And finally the output of the package management system:
    php-mysql.i386                          5.1.6-15.el5          installed

    So maybe you can see some problems.

    Greetings,

    Mike



  • Sorry, here comes the .ini file

    php.txt



  • What you wrote earlier, that the extension 'mysql xml standard pcre session' was not installed… is that still the case?



  • Sorry that I´ve puzzled you. I currently trying to install i-doit on two different Linux flavours: CentOS 5, the one which is most of the thread about and Trustix 2.2, the one with the 'mysql xml standard pcre session' was not installed' error. Trustix is actually the system of our production servers. But while support seems to go down for this great system we are looking for another distro. Centos 5 is now the first test environment and I thought it is a good idea to also implement one or two of this "ever wanted but never had the time to get one" services like an it inventory. There is one included with our Zabbix network monitoring system but it´s much too basic to meet our requirements.
    So while I know my ways around with Trustix I´ve tried to install i-doit on such a system but the setup doesn´t start and just the above error pops up. I´ve tried to find the module but hadn´t any success. If you could point me to the right direction I would be very happy.



  • hmm strage , can you check if networking is enabled in mysqld.
    if you type " telnet localhost 3306" the result should be something like
    Trying 127.0.0.1…
    Connected to localhost.localdomain.
    Escape character is '^]'.
    A
    5.0.22-Debian_3-logmzJhM)#s=s,�Oo`sC5{.rtoQ



  • Her is the output:
    [netadmin@linux3 ~]$ telnet localhost 3306
    Trying 127.0.0.1…
    Connected to localhost.localdomain (127.0.0.1).
    Escape character is '^]'.
    4
    5.0.22%YqLiIs&,`5%Vf{X(\xg|
    As you can see we´re both running the same version of mysql...



  • Related to that
    Need: mysql xml standard pcre session    stuff

    I resolved it by installing php-mysql (running on Centos5)
    yum –disablerepo=* --enablerepo=c5-testing install php-mysql

    restart Apache and try again

    boris



  • you may also want to install thoses additional php libraries:

    yum –disablerepo=* --enablerepo=c5-testing install php-curl
    yum --disablerepo=* --enablerepo=c5-testing install php-ldap



  • Hello, i receive the same message if i open http://localhost/i-doit. (message attached)

    I'm using Linux Mint 18.1 Cinnamon 64-bit

    Can someone tell me how I solve this problem?

    Bildschirmfoto vom 2017-03-23 10-57-54.png


  • i-doIT Team

    Hello derHabi,

    Welcome to our i-doit forums!

    Please take a close look at our knowledge base: https://kb.i-doit.com/display/en/Installation

    Linux Mint 18.1 is based on Ubuntu 16.04 which is currently not supported because of PHP 7. Please switch to another GNU/Linux distribution or just wait for i-doit 1.9. The pro version will be published in May.

    Greetings,
    Benjamin


Log in to reply
 


Datenschutz / Privacy Policy