Ok das war dann ein Missverständnis auf meiner Seite. Die alte API funktioniert erstmal weiter auch im 2.0 nur einige Funktionen sind nur in der neuen API verfügbar.
Danke