LDAP/Nagios Module Probleme



  • Hallo, wir sind gerade dabei i-doit in unser kleines unternehmen einzubinden, nur habe ich schon am anfang probleme mit den beiden modulen LDAP und Nagios.

    also folgendes problem:

    nach einer installation von i-doit 0.9.9-7 inkl. der module LDAP und Nagios , funktioniert der obere reiter "extras"nicht.
    wenn man extras anklickt passiert rein gar nichts, über konsole erhalte ich vom apache folgende fehlermeldung:
    PHP Fatal error:  Class 'isys_module_ldap' not found in /var/data/public/src/classes/ajax/handler/isys_ajax_handler_modules.class.php on line 49

    klickt man unter konfiguration auf LDAP oder Nagios erhalte ich diese fehlermeldung:
    isys_exception_general : isys_module_ldap does not exist! Disable or delete this module in database table isys_module or the i-doit module-manager!
    bzw.
    isys_exception_general : isys_module_nagios does not exist!Disable or delete this module in database table isys_module or the i-doit module-manager!

    mache ich eine installation ohne diese module funktioniert der reiter extras.

    während der installation sind keine fehler aufgetreten und die php LDAP extension ist aktiviert

    bin für jeden tip sehr dankbar , vielen dank 🙂



  • Für das LDAP Modul muss die PHP extension php_ldap installiert und aktiviert sein

    Edit: Achso ich sollte mal weiter lesen 😉 Bist du sicher das die Extension aktiv ist? Hast du den Apache mal neugestartet? Der Fehler ist mir nur in diesem Zusammenhang bekannt.



  • hallo, ich habe jetzt mal den apache neugestartet, das hat aber leider nichts gebracht bekomme immernoch diese fehlermeldung:

    [Tue Nov 08 15:36:38 2011] [error] [client xx.xx.xx.xx] PHP Fatal error:  Class 'isys_module_ldap' not found in /var/data/public/src/classes/modules/isys_module_system.class.php on line 214, referer: http://xx.xx.xx.xx/

    gibt es eine möglichkeit sich anzeigen zu lassen ob die extension richtig  installiert/aktiviert ist ohne dazu i-doit zu nutzen diese menüpunkte kann ich dort nämlich nicht aufrufen.


  • i-doit Kenner

    Hi,

    entpacke mal das entsprechende Update in deine Installation und führe ein Update aus. Es kann sein, dass die ein oder andere Tabelle nicht korrekt angelegt wurde.

    Lieben Gruß
    Christian


 


Datenschutz / Privacy Policy