Problem with the installation: Database port: 3306ERROR (110)



  • hi,

    when I start i-doit and go thought the web installer I get the following errors:
    Database port: 3306 ERROR (110)
    Database username: idoit OK
    Database password: ***** OK
    Database root username: root OK
    Database root password: ***** FAILED
    System Database Name: idoit_system NO LINK
    Database Config: n/a NO LINK
    Database mode: n/a NO LINK
    Mandator database name: idoit_data NO LINK

    I think all of the error are connected to the first error: Database port: 3306 ERROR (110). I have tried to open the database with phpmyadmin and this goes without a problem. Does anyone know how to fix this problem I'm having.

    I also install wamp (all separate packages) on a windows server 2012 and this goes without a problem.

    thank you in advance,

    Wesley


  • i-doit Kenner

    Hi Wesley,

    thank you for your message. The error can have many causes. For example, it may be that not all needed modules have been installed. In our Knowledge Base you can find this information. See https://i-doit.atlassian.net/wiki/pages/viewpage.action?pageId=10223831 as an example for Debian (currently German only but the statements should show you the needed information).

    It is also possible that there is a firewall or a configuration set which prevents a connection. But perhaps only a setting is wrong. 😉

    Kind Regards,
    Christian



  • Hi Christian,

    thank you for your reply, I will have a look in your knowledge base. I allready looked the the possability that my firewall is blocking it, but the firewall is disabled (just to test everythink).

    and what do you mean with not all needed modules are installed?:
    Operating System
    Type: Linux OK
    Version: 3.0.101-63-default #1 SMP Tue Jun 23 16:02:31 UTC 2015 (4b89d0c) OK
    Webserver
    Version: Apache/2.4.16 (Unix) OpenSSL/1.0.1i PHP/5.5.33 OK
    PHP Version: 5.5.33 OK
    PHP Session Extension: Active OK
    PHP MySQL Extension: Active OK
    PHP XML Extension: Active OK
    PHP ZLIB Extension: Active OK
    PHP GD Extension: Active OK
    PHP SimpleXML Extension: Active OK
    PHP Setting "magic_quotes_gpc": Off OK
    PHP cURL Extension: Not found - cURL is not mandatory and only needed for external web-services. Activate it if you're planning to use these services. OK
    PHP PDO_MySQL Extension: Active OK
    PHP Mcrypt Extension: Not found - Mcrypt is not mandatory and only needed for encrypting/decrypting passwords. Activate it if you're planning to use these features. OK
    Database Access Interface (PHP MySQL Extension)
    Version: mysqlnd 5.0.11-dev - 20120503 - $Id: 15d5c781cfcad91193dceae1d2cdd127674ddb3e $ OK



  • @creiss:

    Hi Wesley,

    thank you for your message. The error can have many causes. For example, it may be that not all needed modules have been installed. In our Knowledge Base you can find this information. See https://i-doit.atlassian.net/wiki/pages/viewpage.action?pageId=10223831 as an example for Debian (currently German only but the statements should show you the needed information).

    It is also possible that there is a firewall or a configuration set which prevents a connection. But perhaps only a setting is wrong. 😉

    Kind Regards,
    Christian

    Hi Christian,

    I looked at the knownledge base and I couldn't find the error 110, what I did see is that you (or a college) installed apache/php directly from the repository and not installed it with the source code (what I did).

    something I didn't mentioned yet: I run the webserver with i-doit on a sles 11 SP4 server, can this be the problem?


  • i-doit Kenner

    Hi,

    What I wanted you to see there, is the installation process. There is a different one for SUSE (11 and 12): https://i-doit.atlassian.net/wiki/pages/viewpage.action?pageId=10223840

    As you can see, SLES 11 is described in the bottom of the article but it is not supported anymore.

    I remember SELinux to prevent a local connection between the webserver and the database. Perhaps you have to disable that.

    Kind Regards,
    Christian


 


Datenschutz / Privacy Policy