Keine Standortauswahl (ver. 1.11.1)



  • Hallo liebe Community,

    in der i-doit Instanz unseres Unternehmens lässt sich seit kurzem kein Standort mehr für Objekte anlegen. Die Standortauswahl bleibt komplett blank. 0_1538741024787_keineStandortauswahl.PNG Die Version 1.11.1 ist schon seit längerem eingespielt und es wurden nur Einträge getätigt. Die VM auf der die Instanz läuft wurde nicht angefasst. Daher weiß ich nicht was den Fehler ausgelöst haben könnte.

    Liebe Grüße



  • Auch wir haben Probleme mit dem Standort und wären sehr an einer zeitnahen Lösung interessiert



  • Hallo zusammen,

    das sieht nach dem gleichen Fehler aus den ich unter "Keine Datenverlinkung nach Umzug von Win auf Ubuntu möglich" gepostet habe.
    Nur das ich unter Windows genau dies noch machen kann, aber unter Linux nicht mehr.
    Dachte es hätte was mit dem Umzug zu tun aber es scheint ein genereller Fehler zu sein.

    VG und ein schönes WE


  • i-doit Kenner

    Hi zusammen,

    habt ihr mal in der Verwaltung unter Cache/Datenbank die Standort-Korrektur ausprobiert?

    Lieben Gruß
    Christian



  • Neben dem was Christian gesagt hat wäre auch noch mal interessant zu wissen, ob vielleicht durch irgendetwas das System Objekt "Root-Lokation" gelöscht wurde. Dazu einfach mal die URL http://[mein.i-doit.system]/?objID=1 aufrufen und gucken, ob das Objekt erscheint und ob es im CMDB Zustand "Normal" ist.



  • @dkirsten said in Keine Standortauswahl (ver. 1.11.1):

    ?objID=1

    Hallo zusammen,
    in meinen Falle (open Version) ist das Root Objekt vorhanden und trotzdem ist das oben geschilderte Problem, und auch noch weitere dieser Art, bei mir vorhanden.
    Es scheint hier ggf. ein Problem mit der neuen Version in Verbindung mit Linux und ggf. PHP zu geben.
    Auch eine neu Installierte Version und Ubuntu bringt das hier geschilderte Problem und auch das aus meinem Post hervor.

    MFG
    TheBob



  • Ah, hab es reproduzieren können. mod_rewrite ist nicht aktiv bei Euch. Ich schreib dazu gleich etwas mehr.



  • Um mod_rewrite zu aktivieren müssen 2 Dinge gegeben sein:

    Erstens muss es für Apache aktiviert sein, dass kann man im Normalfall machen mit:

    a2enmod rewrite
    

    und anschließend Apache neu starten.

    Zweitens muss die .htaccess Datei von i-doit "greifen". Damit diese greifen kann, sollte in der Apache Config für den i-doit Pfad der Wert

    AllowOverride All
    

    gesetzt sein. Bei mir sieht das Beispielsweise so aus (/etc/apache2/sites-enabled/i-doit.conf):

    <VirtualHost *:80>
            ServerAdmin i-doit@example.net
    
            DocumentRoot /var/www/html/
            <Directory /var/www/html/>
                    # See /var/www/html/.htaccess for details
                    AllowOverride All
                    Require all granted
            </Directory>
    
            LogLevel warn
            ErrorLog ${APACHE_LOG_DIR}/error.log
            CustomLog ${APACHE_LOG_DIR}/access.log combined
    </VirtualHost>
    

    Nach Änderungen dort ebenfalls den Apache Webserver neu starten. Sollte es immer noch nicht klappen, lohnt sich ein Blick in die allgemeine Apache Konfiguration, meistens /etc/apache2/apache.conf. Dort liegen ggf. noch andere AllowOverride Definitionen, die das ausführen von mod_rewrite verhindern.



  • a2enmod rewrite
    

    war bei mir aktiv

    AllowOverride All
    

    unter /etc/apache2/sites-enabled/i-doit.conf ist auch drin gewesen
    unter /etc/apache2/apache.conf gab es noch einen Eintrag

    <Directory /var/www/>
            Options Indexes FollowSymLinks
            AllowOverride None
            Require all granted
    </Directory>
    

    diesen habe ich auch noch auf All geändert und Apache neu gestartet.
    Leider immer noch keine Besserung.
    Noch eine Idee was ich versuchen könnte?
    Besten Dank und VG
    TheBOb



  • Hi,

    zunächst müsstest Du das Problem erstmal eingrenzen bzw. herausfinden, ob es wirklich bei dir mod_rewrite ist. Geh doch mal auf die i-doit Suche und suche nach irgendwas. Wenn dort ein "The requested URL /search was not found on this server." erscheint, dann liegt es definitiv an mod_rewrite.

    Dann musst Du weiter in Deiner Apache Config bohren, erstmal gucken, ob im i-doit Verzeichnis überhaupt eine .htaccess Datei liegt.
    Um eine übersicht über alle AllowOverride Direktiven zu bekommen, kannst du einfach mal folgendes machen:

    cd /etc/apache2
    grep -R AllowOverride *
    


  • Salue Daniel,

    besten Dank für die Infos.
    Die Suche funktioniert ohne Probleme und auch nach dem Allow hatte ich geschaut und alle Einträge entsprechend geändert und den Apache neu gestartet. Leider ohne Erfolg.

    Sofern ihr auch das ganze unter Linux laufen lasst, könnte ich dann die Info bekommen mit welcher Version von PHP, Apache und SQL ihr das laufen lasst sofern sich diese von den Systemrequirements unterscheidet?

    Besten Dank im Voraus
    VG The Bob



  • Hallo Daniel, hallo Bob,

    Vielen Dank bis hierher schonmal für die aktive Auseinandersetzung mit dem Problem. 😃

    Wenn ich bei mir den Befehl
    *grep -R AllowOverride **
    ausführe, dann habe ich tatsächlich keine .htaccess Datei in der ausgegebenen Liste.
    Dementsprechend funktioniert die Suche auch nicht, genau so wie Daniel es beschrieben hat.

    Was wären denn die nächsten Schritte?

    Beste Grüße
    kanani

    P.S. die Instanz läuft auf Debian 9 stretch bei uns.



  • Hallo Kanani,

    da habe ich mich etwas missverständlich ausgedrückt. Mit dem grep Befehl bekommst Du nicht die .htaccess ausgegeben, sondern nur alle Stellen, an denen der Befehl AllowOverride gesetzt ist. Das AllowOverride ist quasi die Voraussetzung, dass die .htaccess später überhaupt "greift". Die .htaccess liegt im i-doit Hauptverzeichnis, also beispielsweise:

    ls -hal /var/www/html/.htaccess
    

    oder

    ls -hal /var/www/html/[i-doit Pfad]/.htaccess
    

    Die aktuellen Systemvoraussetzungen gibt es immer hier: Systemvoraussetzungen

    Derzeit sind sie:
    Apache Webserver 2.4

    MariaDB 10.0, 10.1 oder MySQL 5.6, 5.7

    PHP 5.6, 7.0, 7.1
    PHP Extensions: bcmath, ctype, curl, fileinfo, gd, imagick, json, ldap, mbstring, memcached, mysqli, mysqlnd, pgsql, session, soap, xml, zip

    Alle Einstellungen zu PHP etc. sind in der Anleitung zur manuellen Installation nachzulesen: Manuelle Installation

    Grundsätzlich ist es am einfachsten, sich die Virtuelle Appliance herunterzuladen: Virtuelle Appliance
    (Liebe nachfolgende Leser, der Link wird bei jedem i-doit Update aktualisiert, d.h. an eine aktuelle URL kommt man über die Anmeldung zur Online Evaluierung).
    Die virtuelle Appliance ist ein aktuelles Debian mit allen optimalen Einstellungen.



  • Danke nochmal für die Hilfe. Ich konnte das Problem jetzt lösen. Suche und Locationpfad funktionieren beide wieder.
    Hier die Configänderungen.
    0_1539335246072_Funktionierend_allowoverride.PNG

    Liebe Grüße


Log in to reply
 


Datenschutz / Privacy Policy