Defekte Icons für Baumdarstellung (dtree) nach Update



  • Hallo zusammen,

    nach den Updates auf die Versionen 1.11.1 und 1.11.2 von i-doit pro hatte ich beide Male das Problem, dass einige Icons für die Baumdarstellung in der Objektansicht links defekt waren. D.h. sie wurden vom Browser nicht angezeigt (statt dessen wurde das Symbol angezeigt, dass der Browser für nicht gefundene Bilder verwendet).

    Auf dem Dateisystem wurde bei den defekten Icons vom Linux-File-Befehl nicht erkannt, dass es sich um Bilder handelt. Hier im Screenshot z.B. joinbottom.gif, join.gif, usw.

    0_1540364676411_dtree.png

    Ich habe die problematischen Icons dann aus dem Backup wiederhergestellt. Aber ich frage mich natürlich, ob evtl. noch weitere und vor allem wichtigere Dateien "defekt" sein könnten.

    Hat das jemand anderes auch schon mal gehabt oder eine Idee, woran das liegen könnte?

    Viele Grüße



  • Ich würde die Ursache außerhalb von i-doit suchen, vermutlich ein Hardware-Problem. Das letzte Update habe ich mir noch nicht angeschaut, aber das Update auf 1.11.1 verlief in der Hinsicht bei uns unauffällig.


  • i-doit Kenner

    Hi,

    das Beschriebene habe ich noch nie erlebt.

    Um dich sicherer zu fühlen kannst du auch noch mal ein Update auf die gleiche Version ausführen und im Log schauen, ob alle Dateien erfolgreich kopiert wurden. Dass Dateien einfach nur beim Update weggelöscht werden, glaube ich nicht. Die sollten nur durch die aus dem Update-Paket ersetzt werden.

    Vielleicht steht aber im i-doit-Verzeichnis im Ordner "log" noch das Update-Log drin. Dort könntest du schauen, ob es beim letzten Update vielleicht Fehler gegeben hat.

    Lieben Gruß
    Christian



  • Danke für die Rückmeldungen. Im Log sind beim Kopieren der Dateien keine Fehler zu sehen. Es werden auch keine Dateien gelöscht, sondern die durch das Update ersetzten Dateien sind teilweise defekt.

    An ein Hardware-Problem glaube ich nicht wirklich, da auf dem Server noch andere Sachen laufen, die keinerlei Probleme machen.

    Ich verwende den automatischen Update-Download über die GUI und habe die Vermutung, dass das Problem beim automatischen Entzippen des Downloads via PHP entsteht. D.h. dass einzelne Dateien dabei "kaputt gehen" bzw. nicht korrekt entpackt werden.

    Beim nächsten Update werde ich den ersten Teil (ZIP-Datei herunterladen und entpacken) manuell machen, wie hier beschrieben.



  • @ernst-lennon

    Hi,

    Ich habe heute das Update 11.1 installiert und hatte ebenfalls Icons die mir nicht mehr angezeigt wurden. Aus einem Backup habe ich dann einen früheren Ordner von "Images" hergestellt, danach wurden wieder alle Icons dargestellt.

    Gruss



  • Ich habe mit der neuen Version 1.12 wieder genau dasselbe Problem!

    Ich lade das Update in der Weboberfläche über "Verwaltung => Systemtools => i-doit Update" herunter. Dann - bevor ich das Update durchführe - schaue ich mir im Dateisystem unter $idoit/updates/versions/v1.12/files/images/dtree/ ein paar der neuen Dateien mit dem file-Befehl an. Dabei stelle ich fest, dass wieder einige Dateien korrupt sind:

    0_1545118937748_screenshot.png

    Entweder sind diese bereits im ausgelieferten Zip-File defekt, oder sie werden nicht richtig entpackt.

    Das Zip-File wird zwar temporär nach $idoit/temp/ geschrieben, aber das Entpacken und Löschen des Zip-Files geht so schnell, dass ich es nicht abfangen kann. Sonst hätte ich es manuell entpackt, um zu schauen, ob die Dateien dann ebenfalls defekt sind. Wenn ich das Update manuell über das Kundenportal herunterlade und entpacke, sind die Dateien in Ordnung.

    Auf die Dauer nervt es, wenn ich immer über das Kundenportal gehen muss.



  • Mit Hilfe des Supports unter help.i-doit.com wurde das Problem nun behoben. Danke!

    Bei uns war die PHP-Extensions php-zip nicht installiert. Vermutlich lag dies daran, dass der Server unter Debian 8 aufgesetzt worden war und dann später - während i-doit bereits installiert war - auf die Debian-Version 9 aktualisiert wurde. Die Zip-Extension von PHP war in der Installationsdoku von Debian 8 nicht als Requirement aufgeführt.

    Beim Überprüfen der installierten Extensions fiel dann noch auf, dass auch die Extension php-mbstring fehlte. Falls jemand also dasselbe Problem hat, am besten mal diese beiden Extensions kontrollieren.


Log in to reply
 


Datenschutz / Privacy Policy