PHP 7.3 recommended!



  • Hello all, I did a fresh installation of i-doit PRO (version 1.13 and already purchased the licenses) and when checking the "System overview & Config Check" it says that the PHP version installed is the 7.2.19-0Ubuntu0.18.04.1" and the recommended version is the 7.3.

    I installed the version 7.3 in my Ubuntu and it is the current version running on that, but when going to the ido-it, it is still using the version 7.2.

    Does anyone know how to update the i-doit to get the "new" 7.3 php version?

    Thank you!!


  • i-doit Kenner

    Hi,

    did you uninstall the old PHP package? Additionally you have to deactivate the old PHP module.

    Kind Regards,
    Christian



  • Hi creiss thanks for your answer. I just uninstalled the version 7.2 and installed the recommended version 7.3 with all the packages, but it stopped to work.

    Them I tried to install the php using the automatic script and it give me an error:

    "PHP 7.3 is installed, but this verison is not officially supported by i-doit. Please consider to downgrade. We recommend version 7.3"

    I'm using Ubuntu 18.04.2 LTS bionic as OS.

    I'm very confuse now, if the "recommended php version 7.3" is really necessary or not, what is the operational system recommended to have everything working at the first installation??

    Best Regards



  • Hello , Did it worked for you ? cause i have the same problem !!
    Cordially


  • i-doit Kenner

    Hi,

    The official system requirement can be found here: https://kb.i-doit.com/display/en/System+Requirements

    Apache Web server 2.4
    MariaDB 10.1, 10.2, 10.3, 10.4 (recommended) or MySQL 5.6, 5.7
    PHP >=7.1.8 (deprecated), 7.2, 7.3 (recommended) or 7.4
    PHP extensions: bcmath, ctype, curl, fileinfo, gd, imagick, json, ldap, mbstring, memcached, mysqli, mysqlnd, pgsql, session, soap, xml, zip
    

    i-doit should work with an older PHP version.

    @Le-Hatem Did you try to disable the older PHP version? Or what is your exact problem?

    Kind Regards,
    Christian



  • @creiss said in PHP 7.3 recommended!:

    Kind Regards,

    Hello , Thanks for your replay ,
    Yes i did and my official version is PHP 7.3.18
    Thank you again



  • @creiss said in PHP 7.3 recommended!:

    with

    I just have a question , DOES IT just work with an older version of PHP ?


Log in to reply
 


Datenschutz / Privacy Policy