Probleme bei der Installation



  • Hallo zusammen,

    ich versuche nun schon seit einigen Tagen i-doit-0.9-beta zu installieren, weil mir das Demo gut gefallen hat und ich das System gerne einsetzen würde.

    Leider habe ich dabei Probleme und ich wäre dankbar, wenn mir jemand weiter helfen könnte.
    Ich verwende SuSE 9.3 mit den geforderten Versionen, apache 2.0.49, mysql 4.1.16, php 5.1.4

    Bei der Webinstallation bekomme ich auf der letzten Seite folgende Meldung:

    | Step 6: Installation
    Installation status

    Creating database connection OK
    Creating system database           OK
    Creating mandator database OK
    Importing system database ERROR
    Installation failed!                     ERROR (1 errors)

    Wenn ich versuche eine idoit manuel zu installieren kommt die Fehlermeldung:

    isys_exception_database : Query error: 'SHOW TABLES LIKE 'isys_registry';': No database selected 
    (Extended Information: array ( 'server' => '4.1.16', 'host' => 'Localhost via UNIX socket', 'client' => '4.1.16', 'proto' => 10, ))
    
     Fatal error: Uncaught Exception occured in (/var/www/i-doit-beta/src/classes/components/
    isys_component_dao_registry.class.php:92): isys_exception_general : Could not find table 'isys_registry' 
    (Extended Information: General exception occured) thrown in /var/www/i-doit-beta/src/classes/components/isys_component_dao_registry.class.php on line 92
    
    

    Diese Tabelle "isys_registry" ist nicht in der Datenbank…

    Ich hab schon viel gesucht, gelesen, ausprobiert, aber irgendwo hats mich.

    Wär super, wenn mir jemand helfen könnte.

    Danke

    lg
    |



  • Sieht so aus als wenn dein mySQL-Server ohne Root-Passwort konfiguiert ist. Bitte konfiguier auf ihm eins, weil im Installer ein Bug entdeckt wurde, der ohne Root-Passwort (also leer) die Installation unmöglich macht. Fixen wir natürlich zum nächsten Release!

    Falls dem nicht der Fall sein sollte, bräuchtem wir Infos wie die Versionen von mySQL, Apache und PHP + zugehöriger Konfiguration, eine phpinfo() - Ausgabe, die src/config.inc.php und einige Debuggingprotokolle aus dem temp Verzeichnis, damit wir den Fehler analysieren können.



  • Hallo,

    Ich hab ein root-Passwort erstellt und schon läuft das Ding.

    Jetzt wird getestet, was das Zeug hält… 🙂

    Vielen Dank für die schnelle Hilfe.

    lg



  • hallo zusammen,

    selbiger fehler mit i-doit0.9b2:

    isys_exception_database : Query error: 'SHOW TABLES LIKE 'isys_registry';': (Extended Information: array ( 'server' => false, 'host' => false, 'client' => '4.1.15', 'proto' => false, ))
    Fatal error: Uncaught Exception occured in (/usr/local/www/i-doit/src/classes/components/isys_component_dao_registry.class.php:92): isys_exception_general : Could not find table 'isys_registry' (Extended Information: General exception occured) thrown in /usr/local/www/i-doit/src/classes/components/isys_component_dao_registry.class.php on line 92

    System  FreeBSD fnki-wsfkoglin2 4.11-STABLE FreeBSD 4.11-STABLE #2: Tue May i386 
    apache 1.3.37
    MySQL-Server 4.1.12
    PHP Version 5.1.6

    config.inc.php
    $g_db_system = array(
            "host"  => "fnki-wsfkoglin2",
            "port"  => 3306,
            "user"  => "i-doit",
            "pass"  => "i-doit",
            "name"  => "idoit"

    [Mon Oct 23 18:45:31 2006] [error] PHP Fatal error:  Uncaught Exception occured in (/usr/local/www/i-doit/src/classes/components/isys_component_dao_registry.c
    lass.php:92): isys_exception_general : Could not find table 'isys_registry' (Extended Information: General exception occured)\n  thrown in /usr/local/www/i-do
    it/src/classes/components/isys_component_dao_registry.class.php on line 92
    /usr/local/www/i-doit/src/classes/components/isys_component_dao_registry.class.php(92) : Fatal error - Uncaught Exception occured in (/usr/local/www/i-doit/sr
    c/classes/components/isys_component_dao_registry.class.php:92): isys_exception_general : Could not find table 'isys_registry' (Extended Information: General e
    xception occured)
      thrown

    die "isys_registry" ist vorhanden –->
    Tables_in_idoit
    isys_const_get
    isys_const_system
    isys_const_system_type
    isys_content_view
    isys_db_init
    isys_ls_language
    isys_ls_substitute
    isys_ls_translation
    isys_mandator
    isys_registry

    da die isysy_mandator auch schon als fehlerquelle genannt wurde, hier auch diese:
    isys_mandator__id    isys_mandator__title    isys_mandator__description    isys_mandator__dir_cache    isys_mandator__dir_tpl    isys_mandator__db_host    isys_mandator__db_port    isys_mandator__db_name    isys_mandator__db_user    isys_mandator__db_pass    isys_mandator__sort    isys_mandator__default_lang_const    isys_mandator__default_language_short
    1 firma (DE) firma cache_firma default fnki-wsfkoglin2 3306 idoit i-doit i-doit 1 ISYS_LANGUAGE_GERMAN de
    2 firma (DE) firma cache_firma default fnki-wsfkoglin2 3306 idoit i-doit i-doit 2 ISYS_LANGUAGE_ENGLISH en

    im /temp ist leider nix zu finden ...



  • Kannst du denn mal die phpinfo()-Ausgabe als Datei anhängen?



  • Hallo, ich hab das (gleiche) Problem: Umgebung: SLES 10, mySQL V 5.x, php5, apache2

    Installation verläuft lt. webinstaller gut - alles grün. Nachdem ich nach der Installation auf NEXT clicke kommt nur:

    isys_exception_database : Query error: 'SHOW TABLES LIKE 'isys_registry';': (Extended Information: NULL)

    Die Tabelle ist aber da?

    Any ideas?

    Gruß, Georg



  • Hi,
    hab den Fehler gefunden, hatte mySQL V 5.x genommen, damit geht es nicht. Steht auch in den Requirements… 😞



  • Also, was alles falsch laufen könnte, wenn es so eine Fehlermeldung gibt ist gar nicht so wenig. Im Prinzip bedeutet es ja, dass die Verbindung zu dieser Datenbank/Tabelle nicht hergestellt werden kann.

    • Falsche Anmeldedaten für mysql in der config.inc.php angegeben

    • Datenbank fehlerhaft installiert

    • Falsche mysql-Version (5.0.22 ist die zuletzt von uns getestete, es wird inwischen aber eine 5.x empfohlen)

    • Falscher Port wird benutzt



  • Also wir hatten das Problem auch und haben mit dem phpmysqladmin einfach den idoit@% user zum idoit@localhost kopiert und schon war das Problem weg.

    Gruß Dirk



  • @gawe:

    Also wir hatten das Problem auch und haben mit dem phpmysqladmin einfach den idoit@% user zum idoit@localhost kopiert und schon war das Problem weg.

    Gruß Dirk

    ICh habe das gleiche Problem, kannst du das mal genauer beschreiben. Aus der SystemDB nehm ich an, welchen user woher wohin kopiert?

    Bin auch seit 2 Tagen am rumprobieren -> no chance yet 😞



  • Wenn Du den phpmyadmin startest kannst Du direkt auf der Startseite auf "Rechte" klicken.
    Dort stand bei uns nur idoit@% mit den enstprechenden Rechten auf die beiden DBs.

    nachdem wir den User zum idoit@localhost kopiert haben funktionierte es ohne Probleme.

    Gruß Dirk

    php.JPG



  • Hi Leute,

    also es ist gefixt, die Jungs von I-DoIt haben mir per E-Mail geholfen, saunett.

    Also, mein Problem war nur:

    Es lag an den Berechtigungen auf die i-doit Verzeichnisse, wie bereits in meiner ersten Mail beschrieben war 🙂 Jedoch muss in einer lampp Umgebung der User "nobody" volles Recht auf unsere Cache-Verzeichnisse bekommen, und nicht wie beim regulärem Apache der User "www-data".
    Die Berechtigungen habe ich mit dem Befehl:
    cd /opt/lampp/i-doit/
    chown -R nobody:www-data ./temp ./src/themes/default/smarty/templates_c
    ./src/themes/default/smarty/cache
    gesetzt.



  • ERROR (#1031: Table storage engine for 'isys_drive_list_2_stor_list' doesn't have this option)
    Bekomme diesen Fehler Bitte um Hilfe


  • administrators

    Hi,

    ich glaube Du bist ein paar Jahre zu spät im Thread 😃

    Welche Version setzt Du ein?

    Viele Grüße,

    Daniel


 


Datenschutz / Privacy Policy