I-doit 1.8 OPEN Database Error



  • Hallo liebes i-doit-Team,

    wir haben vor ein paar Wochen von der 1.4.8 OPEN auf die 1.8 OPEN geupdated.
    Soweit funktioniert auch alles, bis auf die Suche im Layer-3-Netz.
    Wenn man dort eine IP eingibt, wirft i-doit einen Datenbankfehler aus (habe einen Screenshot angehängt).
    Sobald diese Fehlermeldung dann auftritt, kann man den Objekttyp eine Zeit lang nicht mehr öffnen.
    Falls es euch was nützt, habe ich noch die Versionen der Module angehängt.
    Die MariaDB-Version ist diese: mysql  Ver 15.1 Distrib 10.0.28-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2
    Und die Debian-Version ist folgende: Linux version 3.16.0-4-amd64 (debian-kernel@lists.debian.org) (gcc version 4.8.4 (Debian 4.8.4-1) ) #1 SMP Debian 3.16.36-1+deb8u2 (2016-10-19)

    Ich habe auch schon in der Verwaltung versucht, unter "System tools" die Datenbank zu reparieren (Execute all actions) aber das hat nichts gebracht.

    Würde mich freuen wenn Ihr mir helfen könntet.

    Fehlermeldung.png
    versionen.png


  • i-doit Kenner

    Hi,

    da wäre jetzt die erste Frage, nach was genau in welcher Spalte gefiltert wurde. Dass der Objekttyp eine Zeit lang nicht aufgerufen werden kann hängt damit zusammen, dass der Filter, durch den der Fehler ausgelöst wird, eine gewisse Zeit lang gespeichert wird. Das kannst du einfach in deiner Benutzereinstellung unter "System settings" ändern.

    Lieben Gruß
    Christian



  • Hey nochmal,

    Vielen Dank für den Hinweis mit der Speicherung der Filter, ich habe diese jetzt auf 0 gesetzt, dann kann man wenigstens gleich weiterarbeiten und muss keine 300 Sekunden warten.
    Habe ich den Filter nicht mit der Suche aktiviert?
    Außerdem steht am Schluss von der Fehlermeldung "Unknown column 'isys_cmdb_dao_category_s_net_ip_addresses__ip_address_link' in 'having clause'".
    Es sieht so aus als möchte er auf eine Spalte filtern, die es gar nicht gibt.
    Ich möchte eigentlich nur nach IPs suchen.
    Ich sehe auch grade, dass die Spalten verrutscht sind, z.B. steht der CMDB Status bei Assigned adresses drin und die Subnetzmaske bei Adress range.
    Wenn ich aber einen Adressbereich öffne, steht dort alles richtig drin, ich hab da mal einen Screenshot angehängt.
    Vielleicht ist das das Problem?
    Ich habe auch grad das Changelog zur 1.8.2 PRO gelesen, dort steht: "[Bug]          Neu angelegte IP-Adressen werden über die Suche nicht gefunden".
    Vielleicht ist genau das auch mein Problem.
    Es wäre auch super, wenn man nach dem Titel der Netze sortieren könnte, das habe ich bis jetzt nicht gefunden.

    spaltenansicht.png


  • administrators

    Hallo,

    also was die Liste angeht, bitte mal folgendes durchführen:

    • In der Verwaltung unter System tools / Cache Database / Renew Properties ausführen

    • Die Listenansicht auf Standard zurücksetzen und abspeichern

    • Die Listenansicht neu nach belieben konfigurieren und abspeichern

    Nach dem Titel der Netze sollte man spätestens dann auch sortieren können.



  • Habe grade alles gemacht, so wie Sie es geschrieben haben.
    Die Titel werden endlich wieder einwandfrei angezeigt, vielen Dank!
    Die Suche an sich funktioniert auch, wenn man genau die Spalte angibt, die durchsucht werden soll und Sie den genauen Wortlaut wie der Suchbegriff hat.

    Jetzt hab ich noch eine andere Frage, und zwar würde ich gerne den Tenant bzw. Mandantenname ändern, aber im Admin-Center finde ich den Tab "Tenants" nicht. Dort kann man doch normalerweise auch die Tenants editieren, aber das gibt es bei mir nicht zum anklicken. Kann man das vielleicht in PHPmyAdmin ändern oder über i-doit selber?

    admincenter.png


  • administrators

    Hi,

    die Tenant Namen kann man in der Open auch nur über MySQL ändern. Er steht in der Datenbank idoit_system in der Tabelle isys_mandators.



  • Vielen Dank, das hat gut funktioniert!


 


Datenschutz / Privacy Policy