Jdisc Import - Seriennummern werden nicht erkannt



  • Guten Tag zusammen,
    wir nutzen JDisc für die automatische Inventur und importieren die Daten dann in iDoit. Ich habe nun insbesondere bei Druckern festgestellt: JDisc findet die Seriennummer des Druckers, iDoit importiert sie und trägt sie wie gewünscht bei dem Drucker ein. Allerdings kann ich an keiner Stelle nach dieser Nummer suchen, weder in der Suchleiste oben noch in der Listenansicht, weder Teilstrings noch den kompletten String.
    Wenn ich aber nun die Model-Seite öffne, auf Bearbeiten klicke und - ohne etwas zu ändern - wieder auf Speichern klicke, dann kann ich danach suchen und die Seriennummer wird sofort gefunden.

    Woran kann das liegen, und wie kann ich das eventuell verhindern?

    Vielen Dank und freundliche Grüße

    Tobias


  • administrators

    Hallo Tobias,
    damit die Suche sauber funktioniert gibt es die Möglichkeit nach dem JDisc Import über den Controller mit der Option "-b" den Suchindex neu zu generieren:
    https://kb.i-doit.com/display/de/JDisc+Discovery

    Des weiteren bietet es sich an einen Cron Job einzurichten der den Suchindex zyklisch neu generiert:
    https://kb.i-doit.com/display/de/Suche

    Ich hoffe ich konnte dir mit diesen Infos helfen 😉

    Gruß
    Martin Hartkopf



  • Hallo Martin,
    danke für die Info, das ist glaube ich genau das, was ich gesucht habe. Auf den ersten Blick wurden die Seriennummern jetzt auch gefunden.
    Der Import geschieht ohnehin bereits täglich über einen Task (wir nutzen einen Windows-Server mit XAMPP als Basis). Ich habe jetzt einfach den b-Parameter hinzugefügt und manuell angestoßen. Wenn ich das jetzt täglich mache, brauche ich dann den Job mit dem Suchindex noch? Oder reicht das? Was ist da der bessere Weg?

    Danke und schöne Grüße

    Tobias


  • i-doit Kenner

    Hallo Tobias,

    wenn du den Suchindex direkt beim Import erneuern lässt, sollte das so passen.

    Ich selber gehe aber bei den Systemen von meinen Kunden hin und lasse den Suchindex nach dem Import nicht generieren, sondern lösche die entsprechende Datenbanktabelle und lasse danach den Suchindex neu generieren. Ist "gefühlt sauberer".

    Das Skript von synetics selber, was ich selber immer verwende, findest du unter https://kb.i-doit.com/display/de/Cronjobs+einrichten#Cronjobseinrichten-EssentielleJobsanlegen

    Komischerweise haben die Kollegen die Stelle, an der die DB gelöscht wird, entfernt. Wäre für mich jetzt auch interessant zu wissen, warum…

    In der alten Version siehst du, was ich meine:
    https://kb.i-doit.com/pages/diffpagesbyversion.action?pageId=61015670&selectedPageVersions=10&selectedPageVersions=11

    Lieben Gruß
    Christian


 


Datenschutz / Privacy Policy