Probleme beim Update von 1.3.3 auf 1.4



  • Hallo allerseits

    Ich versuche nun seit ein paar Stunden mein System von version 1.3.3 auf Version 1.4 upzudaten. Ich habe mir das Paket idoit-1.4-update.zip heruntergeladen und den Inhalt vom Verzeichnis updates ins Verzeichnis /var/www/i-doit/updates kopiert ( so wie allen anderen Updates auch). Anschliessend habe ich das  ./idoit-rights.sh set durchgeführt.

    Wenn ich nun den update-Manager aufrufe, erhalte ich das, was ich mit den Printscreens angehängt hab.

    Warum steht dort, das meine Version <= 0.9 ist, und wieso wird mir vorgeschlagen, i-doit - 0.9.9-5 von 2010 herunterzuladen?

    Kann mir jemand beim Update helfen?

    Danke und Gruss
    Nadine

    1.jpg
    2.jpg
    3.jpg


  • i-doit Kenner

    Hallo Nadine,

    das ist wirklich merkwuerdig. Deine PHP Extensions sind auch nicht die, welche normalerweise fuer Version 1.3.3 gebraucht werden. Unter dem Punkt "already downloaded versions" wird Dir auch gar nicht die Version 1.4 angezeigt, da scheint beim Entpacken oder bei der Rechtevergabe irgendwas schief gelaufen zu sein. Hast Du die Rechte bereits ueberprueft?

    Es gibt ein anderes Vorgehen, welches Du vielleicht ausprobieren kannst (wobei es theoretisch auf das selbe hinaus laeuft):
    Kopier die idoit-1.4-update.zip nach /var/www/i-doit/updates und entpacke aus dem Verzeichnis /var/www/i-doit/ die Datei updates/idoit-1.4-update.zip, danach die Rechtevergabe anpassen (wobei ich 777 niemals vergeben wuerde…).

    Hilft das weiter?

    Gruss,
    jkondek



  • Hallo jkondek

    Ich habe es jetzt so gemacht wie Du es beschrieben hast. Der Fehler ist allerdings immer noch der gleiche. Nach einem ./idoit-rights.sh set haben ich zusätzlich noch ein "chown -R www-data:www-data /var/www/i-doit/ " gemacht, auch ohne Ergebnis.
    Jetzt habe ich mal das komplette Verzeichnis updates geleert und nur den Inhalt von v1.4 kopiert (vorher waren da ja noch /versions/v1.3, /versions/v.1.3.1 etc.). Immer noch das gleiche Problem.

    Die rechte sehen so aus:

    drwxrwxr-x 15 www-data www-data    4096 Apr 28 12:29 .
    drwxr-xr-x  3 root    root        4096 Mär 11 12:10 ..
    drwxrwxr-x  6 www-data www-data    4096 Apr 28 12:29 admin
    -rw-r–r--  1 www-data www-data  114036 Jul  1 11:29 CHANGELOG
    -rwxr-xr-x  1 www-data www-data    314 Jul  1 11:29 controller
    -rw-r--r--  1 www-data www-data  11085 Jul  1 11:29 controller.php
    -rw-r--r--  1 www-data www-data    1141 Jul  1 11:29 CREDITS
    drwxrwxr-x  2 www-data www-data    4096 Okt  4  2013 cron
    -rw-r--r--  1 www-data www-data    1406 Apr 28 12:25 favicon.ico
    -rw-r--r--  1 www-data www-data 8158837 Feb 21 07:49 idoit-1.2.5-update.zip
    -rw-r--r--  1 www-data www-data 7932283 Feb 21 07:49 idoit-1.2.zip
    -rwxr-xr-x  1 www-data www-data    3983 Jul  1 11:29 idoit-rights.sh
    drwxrwxr-x 18 www-data www-data    4096 Apr 28 12:29 images
    -rwxr-xr-x  1 www-data www-data    256 Jul  1 11:29 import
    drwxrwxrwx  4 www-data www-data    4096 Jul  2 14:32 imports
    -rw-r--r--  1 www-data www-data    5799 Jul  1 11:29 index.php
    -rw-r--r--  1 www-data www-data    4013 Jul  1 11:29 INSTALL
    -rw-r--r--  1 www-data www-data      29 Jul  1 11:29 LICENSE
    -rw-r--r--  1 www-data www-data    381 Jul  1 11:29 Makefile
    -rwxr-xr-x  1 www-data www-data    418 Jul  1 11:29 mandator
    drwxrwxr-x  3 www-data www-data    4096 Feb 21 10:53 nagiosexport
    -rw-r--r--  1 www-data www-data    4184 Jul  1 11:29 proxy.php
    -rw-r--r--  1 www-data www-data      5 Jul  1 11:29 REVISION
    drwxrwxr-x  5 www-data www-data    4096 Okt  4  2013 setup
    drwxrwxrwx  8 www-data www-data    4096 Jul  1 11:29 src
    drwxrwxr-x  3 www-data www-data    4096 Okt  4  2013 syslog
    drwxrwxrwx  3 www-data www-data  28672 Jul 17 08:20 temp
    -rw-r--r--  1 www-data www-data    2764 Jul  1 11:29 UPDATE
    -rwxr-xr-x  1 www-data www-data    455 Jul  1 11:29 updatecheck
    drwxrwxr-x  6 www-data www-data    4096 Jul 17 13:11 updates
    drwxrwxr-x  4 www-data www-data    4096 Okt  4  2013 upload
    drwxrwxr-x  2 www-data www-data    4096 Okt  4  2013 xsd
    drwxrwxr-x  2 www-data www-data    4096 Okt  4  2013 xs

    Das sollte meiner Meinung nach ja alles OK sein, oder? Ein 777 möchte ich auch nur ungern machen.

    Konntest Du denn das Update installieren?

    Danke und Gruss
    Nadine


  • i-doit Kenner

    Hallo Nadine,

    bei mir hat das Update reibungslos funktioniert.

    Was steht bei Dir in REVISION und in VERSION drin?
    Was erhaelst Du fuer eine Ausgabe wenn Du den updatecheck durchfuehrst?

    Gruss,
    jkondek



  • Hallo jkondek

    Komme leider erst jetzt wieder dazu, mich dem Problem anzunehmen.

    In /var/www/i-doit/REVISION steht: 17722
    In /var/www/i-doit/updates/versions/v1.4/files/REVISION steht: 17723

    In /var/www/i-doit/updates/versions befindet sich das Verzeichnis v1.4 Eine Datei VERSION finde ich nirgends.

    Ein Updatecheck schlägt mir i-doit - 0.9.9-5 Date: 2010-02-10 (rev 6945) vor, was ich halt so gar nicht verstehe (siehe Anhang).

    Danke und Gruss
    Nadine

    i-doit.jpg


  • i-doit Kenner

    Hallo Nadine,

    gibt Dir der updatecheck unter /var/www/idoit/ das gleiche Ergebnis aus wie der Updatecheck der Weboberflaeche?

    Dass Du keine Datei VERSION hast liegt daran, dass Du lediglich den Ordner updates aus dem zip-file kopierst, und nicht das gesamte zip-file in das entsprechende Verzeichnis updates/ kopierst, wie ich es vorgeschlagen hatte. Allerdings denke ich nicht, dass die Existenz dieser Datei irgendeine Rolle spielt…

    Allerdings gehen mir auch langsam die Ideen aus, was Du noch ueberpruefen koenntest. Wie waers mit neu installieren?

    Gruss,
    jkondek



  • Hallo jkondek

    Beim Updatetest auf der Konsole erhalte ich:

    • Checking… Please wait..

      • Theres a new i-doit version available: 1.4.1
      • Your current version is: 1.3.3
      • Go to the i-doit updater to download automatically or download yourself at:
      • http://www.i-doit.org
      • Sieht also gut aus.

      Ja, ich werde das ganze mal auf einer anderen Kiste installieren. Das hatte ich zwar schon mal versucht, bin aber beim Import der DB gescheitert, aber vielleicht klappts ja diesmal.

      Danke und Gruss
      Nadine


  • i-doit Kenner

    Hallo Nadine,

    ich bin ueberfragt, sorry. Installier mal neu, vielleicht funktioniert es dann besser. Ich vermute, dass die Neuinstallation ganz normal funktionieren wird, warum Dein jetziges System so Probleme mit dem Update macht ist natuerlich schade…

    Bei dem Import der DB ist darauf zu achten, dass Du nur die Mandator-DB importierst, nicht die System-DB, ausserdem sollten die DBs gleich heissen (was vermutlich auf Grund Deiner Lizenz gegeben sein muss).

    Gruss,
    jkondek


  • i-doit Kenner

    Hi,

    mir ist diese Art Problem auch noch nicht untergekommen. Ich würde hier einfach noch mal das Update-Paket aus dem Kundenportal herunterladen und im Hauptverzeichnis entpacken. Dabei dann natürlich alle Dateien ersetzen und die Rechte richtig setzen.

    Alternativ würde ich das Update-Paket für die letzte Version herunterladen, genau so verfahren und ein Update auf die gleiche Version durchführen und danach erneut das Update auf die 1.4 probieren.

    Lieben Gruß
    Christian



  • Hallo zusammen

    Also vielleicht bin ich ja einfach nur blöd, aber bei der Neuinstallation scheitere ich an der Datenbank. Wenn ich die komplette Data-DB (asm_data) importieren will erhalte ich den Fehler, das die DB schon exisitert. Logisch, also asm_data gelöscht. Dann erhalte ich beim Import:

    ERROR 1005 (HY000) at line 26174: Can't create table 'asm_data.#sql-3cf_3c5a' (errno: 150)

    Also hab ich probiert die Tabellen zu leeren oder zu löschen, damit ich nur diese importieren kann. Dort bekomme ich die Meldung, das ich den Primary Key nicht löschen oder leeren kann.

    Wie zum Geier krieg ch denn jetzt die Daten von A nach B?

    Ich versuche das ganze auf dem System zu installieren, auf dem unser OTRS läuftKann ersterer Fehler damit zu tun haben, das die default storage engine auf MYISAM gestellt ist?

    Ich setz jetzt einfach nochmal ne VM auf, muss ja irgendwie funktioneren….

    Gruss
    Nadine


  • i-doit Kenner

    Hi,

    zu dem Fehler gab es sogar hier im Forum schon Lösungen: http://forum.i-doit.org/index.php/topic,1472.msg6542.html#msg6542

    MySQL gibt dazu auch Informationen: http://dev.mysql.com/doc/refman/5.1/de/innodb-error-codes.html

    Dort steht im speziellen:

    Tabelle kann nicht angelegt werden. Wenn die Fehlermeldung auf errno 150 verweist, schlug die Tabellenerzeugung fehl, weil ein Fremdschlüssel-Constraint nicht richtig gebildet wurde.

    Lieben Gruß


 


Datenschutz / Privacy Policy