I-doit 1.9 Pro - Admin-Center Header-Error



  • Hallo,

    habe eben das Update auf die i-doit 1.9 Pro durchgeführt …. doch leider spinnt nun das Admin-Center:
    Unable to start session! Headers already sent. There should not be any output before the session starts!

    Somit funktioniert das Admin-Center nur noch als Anzeige des Home-Screens, sämtliche Links/Funktionen versagen.

    Hat noch wer das Problem?

    LG
    Stefan


  • administrators

    Hallo,

    lösch mal in Deinem Browser den Verlauf, Cookies, Cache bezüglich der i-doit Instanz. Es kann sein, dass noch eine Session im Admin Center "hängt". Den i-doit Cache zu löschen unter den Systemttols in der Verwaltung kann auch nicht schaden.



  • Hallo,

    ich habe nach einem Upgrade auf 1.9 auch das Problem.
    Cache löschen in der Systemverwaltung hat leider nicht geholfen.

    Ist ein Bug in mit dem Admin Center unter 1.9 bekannt ?

    Viele Grüße
    Fe



  • Hallo,

    also hier funktioniert das Admin-Center nach unserem Update am Freitag.

    Cache löschen am besten immer in der i-doit Verwaltung und im Browser.

    Ciao

    Sven



  • Hallo,

    leider keine Besserung.
    Ich habe den Cache in i-doit geleert.
    Den Browser Cache geleert-
    einen anderen Browser auf einem anderen PC probiert.

    ich habe das Update noch einmal eingespielt, ohne Fehler.
    Aber auf dem Admin Center kommt immernoch
    "Unable to start session! Headers already sent. There should not be any output before the session starts!"

    kann ich das loging von i-doit erhöhen das ich sehe was genau er sendet ?

    lg
    Fe



  • Hallo,

    bei uns auch keine Besserung, egal was ich mit den Caches anstelle (i-doit, Browser, Java), oder auf nen anderen PC gehe, oder den gesamten WEB-Server durchstarte, aufräume etc.
    So viele Caches gibt es gar nicht, die ich gelöscht habe. 😉
    idoit läuft bei uns in einer XAMPP Umgebung, welche ich am WE aktualiserte. (allerdings noch kein PHP 7)

    … auch keine Besserung

    Ich setze i-doit pro nun seit 02/2014 ein, das Problem hatte ich bis dato nach einem Update nicht.
    Da hat sich wohl irgendwo was festgefressen.

    LG
    Stefan



  • Hallo,

    hängt vielleicht damit zusammen:

    wenn ich mich in i-doit anmelden möchte, wird der Login am linken Bildschirmrand angezeigt, sollte doch mittig sein und etwas eleganter - siehe Anhang1, da ladet wohl ein Design nicht?

    Melde ich mich an und wieder ab, sieht das Loginfenster wie gewohnt aus - siehe Anhang 2.
    Aktualisiere ich nun die Seite (F5) bin ich wieder bei Anhang 1.

    Ausgabe aus Firebug:

    Warning:  Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\idoit\src\lang\en.inc.php:2) in C:\xampp\htdocs\idoit\src\tools\css\css.php on line 26

    Möglicherweise hängt dies mit dem  Admin-Center-Problem zusammen?

    LG
    Stefan

    anhang_1.JPG
    anhang_2.JPG



  • Hallo,

    wenn ich das richtig verstanden habe, ist das ein Bug in der ursprünglich erschienenen Version 1.9 der in 1.9v2 nicht mehr enthalten ist. Ich habe das Update erst vergangenen Freitag gemacht, da war dieser Bug schon behoben.

    Leider steht das "v2" nicht im GUI. Im Update-Bereich wurde mir das auch nur als 1.9 angeboten.

    Ciao

    Sven


  • i-doit Kenner

    Hallo zusammen,

    das kann ich nur bestätigen. Ein Update auf die v2 und danach den Cache löschen sollte das Problem beheben.

    Lieben Gruß
    Christian



  • Hallo,

    danke für den Hinweis.
    Ist bei mir nun auch erfolgreich (auch ohne den Cache zu löschen)

    Ich werde nie verstehen, warum eine Modifikation ohne Releaseanhebung (Iteration) ausgeliefert wird, sodass dies einwandfrei kommunizierbar und somit verteilbar wird.
    Soetwas sollte nicht passieren, eine 1.9.1 wäre doch nicht verkehrt gewesen um diese im Update-Modul zu sichten … auch wenn es 5min nach Release der 1.9 war.

    Danke nochmals für den Hinweis mit der v2.

    LG
    Stefan



  • Hallo,

    update auf 1.9v2 hat geholfen ja 🙂

    Vielen Dank
    Fe



  • @StefanP74:


    Ich werde nie verstehen, warum eine Modifikation ohne Releaseanhebung (Iteration) ausgeliefert wird, sodass dies einwandfrei kommunizierbar und somit verteilbar wird.
    Soetwas sollte nicht passieren, eine 1.9.1 wäre doch nicht verkehrt gewesen um diese im Update-Modul zu sichten ... auch wenn es 5min nach Release der 1.9 war.
    ...

    Da kann ich ehrlich gesagt nur zustimmen. Das stiftet nur Verwirrung. Ich wurde beauftragt, auf 1.9v2 zu aktualisieren, angeboten wurde mir über das GUI nur 1.9 und danach nichts mehr. Hab ich jetzt v2 oder nicht? Hab ich, aber sehen kann man das nicht wirklich. Da war ich anfangs etwas verwirrt.

    Ciao

    Sven


  • administrators

    Kritik ist angekommen und verstanden. Das machen wir das nächste Mal besser.



  • Hallo,

    um nicht nur zu kritisieren: Ich kann für mich sagen, dass die Zusammenarbeit mit dem Support wirklich gut ist und ich die Hilfsbereitschaft hier im Forum echt prima finde. Also auch ein Lob an Synetics, ihr habt ja auch ein tolles Produkt. 🙂

    Ciao

    Sven


 


Datenschutz / Privacy Policy