CSV exportieren in benutzerdefinierter Multi-Value-Kategorie



  • Hallo,

    wir haben diverse Multi-Value Kategorien selbst erstellt. In der CMDB-Ansicht gibt es bei all diesen eine "Als CSV exportieren".
    Das funktioniert leider nicht - die CSV beinhaltet nur den Tabellenkopf der Multi-Value-Tabelle.

    Jemand eine Idee, woran das liegen kann? Im Log ist kein Fehler zu finden.

    Im Einsatz: i-doit Pro 1.11.

    Grüße,
    Marcel



  • Hallo Marcel,

    hab es eben mal getestet. Bei uns tritt der Fehler auch auf. Setzen ebenfalls 1.11 PRO ein.

    Viele Grüße
    Tobias


  • i-doit Kenner

    Hallo zusammen,

    welche Multi-Value-Kategorie exportiert ihr denn? Bei den Clustern kann ich die Clustermitglieder "problemlos" exportieren. Habe das "problemlos" aber auch in Anführungszeichen gesetzt, weil zwischen den Werten keine Trennung ist und das meiner Ansicht nach damit auch nicht perfekt funktioniert.

    Habt ihr ein konkretes Beispiel?

    Lieben Gruß
    Christian



  • @creiss said in CSV exportieren in benutzerdefinierter Multi-Value-Kategorie:

    welche Multi-Value-Kategorie exportiert ihr denn?

    Alle, die wir selbst erstellt haben.

    Bei den Clustern kann ich die Clustermitglieder "problemlos" exportieren. Habe das "problemlos" aber auch in Anführungszeichen gesetzt, weil zwischen den Werten keine Trennung ist und das meiner Ansicht nach damit auch nicht perfekt funktioniert.

    Das sind ja fertige Multi-Value Kategorien oder?



  • @tobiasm said in CSV exportieren in benutzerdefinierter Multi-Value-Kategorie:

    hab es eben mal getestet. Bei uns tritt der Fehler auch auf. Setzen ebenfalls 1.11 PRO ein.

    Danke! Ich hab mal ein BugReport aufgemacht.

    Grüße,
    Marcel



  • Hab es eben noch mal etwas genauer getestet. Also eingebaute Multi-Value Kategorien scheinen zu funktionieren.

    Nur mit den benutzerdefinierten Multi Value Kategorien klappt es noch nicht.


  • i-doit Kenner

    Hallo zusammen,

    habe es gerade mal in der Demo-Umgebung von i-doit selber ausprobiert. Dort gibt es den Objekttypen "Firewall" mit der benutzerdefinierten Multi-Value-Kategorie für die Regeln. Dort konnte ich die Liste mit den Einträgen problemlos exportieren. Aber eben ohne ein Komma zwischen den Werten.

    Was mir aber aufgefallen ist, ist, dass ich erst mal den Cache in der Verwaltung löschen musste, weil die Werte in der Liste selber nicht angezeigt wurden. Danach ging das aber. Habt ihr mal probiert den Cache zu löschen?

    Lieben Gruß
    Christian



  • Bei der Kategorie Firewall-Regeln unter "Router" erhalte ich eine inhaltslose CSV. Wenn du "Fire E." als Kategorie im Objekttyp Fire Exinguisher meinst, dann erhalte ich da auch nur eine CSV mit Header aber ohne Inhalt. Cache löschen half auch nicht.

    Grüße,
    Marcel



  • Der Bug soll in Version 1.11.1 behoben werden.


Log in to reply
 


Datenschutz / Privacy Policy